Support » Plugin: User Admin Simplifier » Cannot hide taxonomy submenus

Viewing 9 replies - 1 through 9 (of 9 total)
  • Thread Starter João Paulin

    (@joao_paulin)

    Hi Adam,

    Sorry for the inconvenience. I see that I am able to hide “Categories” submenu under “Posts”. The problem is to hide custom taxonomies unders custom post types menu. It just doesn’t work!

    I have a custom post type named “Project”, and a custom taxonomy named “Project Type” and I can’t hide “Project Type” submenu from “Project”.

    How can it be fixed?

    Thanks in advance,
    João.

    Plugin Author Adam Silverstein

    (@adamsilverstein)

    I would be happy to take a look to see how this can be fixed. could you post a (link to or) some sample code I can use to reproduce the issue? Or describe how you created the custom taxonomy? Once I can reproduce the issue I will try to figure out how to fix it.

    Thread Starter João Paulin

    (@joao_paulin)

    Hi Adam,

    What I did was:

    1. Installed Pods Plugin (http://wordpress.org/plugins/pods/)
    2. Created a Custom Post Type named ‘Project’
    3. Created a Custom Taxonomy named ‘Project Type’
    4. Associated ‘Project Type’ Taxonomy with ‘Project’ Custom Post Type

    But, when I try to hide the submenu ‘Project Type’ of the ‘Project’, it doesn’t work. It seems that it has worked when you click to save, but when you go check, the submenu is still not selected (and still appears to that user).

    It happened to me before in another project, where I’ve done the same (Custom Post Type, with Custom Taxonomy associated, and tried to hide Custom Taxonomy submenu). It seems like a problem that just occurs on that scenario.

    Thanks in advance,
    João.

    What option were you using to hide the taxonomy submenu?

    Thread Starter João Paulin

    (@joao_paulin)

    Hi Scott,

    What you mean with “option”?

    I simple went to “Tools > User Admin Simplifier” chose the user, and, in the “Project” menu, I clicked the plus sign button (+) and selected only “Project Type”, but when I click to save, it doesn’t save, it is still not hidden.

    Thanks,
    João.

    Oh I misunderstood 🙂

    I’ll keep watching this thread in case it’s anything related to the Pods plugin.

    Plugin Author Adam Silverstein

    (@adamsilverstein)

    João –

    Thanks for your detailed description and for catching this bug. The issue in short was that the key value I was using to store the disabled setting for the submenu contained a disallowed character. By processing all the keys with ‘sanitize_key’, the new version ensures safe key values.

    This update should fix the problem you were seeing with the pods submenu, it did in my local testing. Please update the plugin and let me know if the issue is corrected.

    Thanks again for reporting the bug, this could easily have been affecting other users trying to disable submenus.

    Thread Starter João Paulin

    (@joao_paulin)

    Hi Adam,

    Thanks! It did solve the problem!

    Thank you again,
    João.

    Plugin Author Adam Silverstein

    (@adamsilverstein)

    great!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Cannot hide taxonomy submenus’ is closed to new replies.