Support » Plugin: Simple BuddyPress Profile Privacy » Cannot have my members visible

  • lama010101

    (@lama010101)


    Hi Justin,
    I installed your plugin Simple Buddypress Profile Privacy on my new site https://wesh.site/, and since then I can only see 3 profiles in the Member directory and not the other 5 members. It seems the plugin automatically hid the members! I deactivated the plugin but to no avail. I activated it again and chose No for some members to “Hide My Profile from Member Directory”, but the problem remains, they will not appear here: https://wesh.site/en//members/ (though their profiles exist).
    Do you have any suggestions? Is there a code somewhere that would have been introduced and that would stay even after I deactivate your plugin? I’m not a programmer but I could try look into the files.
    Thank you for your (much needed) help.
    Laurent
    Note: I tried to contact you on your home page but got an error after sending the message “Failed to send your message. Please try later or contact the administrator by another method.”

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Fencer04

    (@fencer04)

    There is nothing permanent in the code that would stay there after you inactivate it. Please try deactivating all the other plugins with the exception of BuddyPress and see if that resolves it. If it does try activating Simple Buddy Press Profile Privacy and see if it works as intended. If it does then there is a conflict with another plugin.

    Please try those steps and let me know what happens.

    Thank you Justin for your quick reply.
    I am working on creating a staging site to debug the issue (yes, I should have done it before…!)
    Right now, I was able to make some profiles visible by (I think) inviting them to be friends with me as Admin and invite them to join groups, so they would at least appear in groups. It works indeed, as they now appear in the directory.
    However, when I try to hide some Admin users, they still show up in the directory, as if your plugin had no impact on show/hide.
    Anyway, I think I will deactivate your plugin altogether because the promise is very good but even if I were to make it work, I don’t want my new users to be hidden by default (all the contrary since I want to build a social network). As a minimum, Admins should have the option to set up the default value (and if this setting exists somewhere, I could not find it).
    Thanks again for your quick support.
    Cheers
    Laurent

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.