Support » Plugin: SSL Zen - Free SSL Certificate & HTTPS Redirect for WordPress » Cannot go past Step 1 after recent update

  • Resolved mohammedkadhim

    (@mohammedkadhim)


    Hello,
    I’ve used SSL Zen in past with no issue. However today I tried to install the plugin on a new site but I’m stuck on Step 1. All system checks are green but then after entering all details (including c-panel credentials) on step 1 nothing happen after pressing “Next”. I only see the loading icon and that’s it. I tried again on different subdomain and still stuck on step 1. It may (also may not) related to the recent update.

    Kind regards,
    Mohammed Kadhim

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Contributor SSL Zen – Support

    (@sslzensupport)

    Hello Mohammed,

    Thank you for contacting us.
    Please reach out to us via plugin or website beacon,we’d be happy to fix the bug for you.

    martinjstephens

    (@martinjstephens)

    Hi,

    I am experiencing the same issue. I provide the CPanel login details, however the plugin does not get past this step.

    I don’t recall the plugin requesting CPanel login details on the free plan before, what is the reason for this addition?

    Martin

    Thread Starter mohammedkadhim

    (@mohammedkadhim)

    @martinjstephens
    I tried multiple solutions none worked for me. The last thing I tried is updating to the most recent version 3.0.15 which supposedly have cpanel login disabled but still stuck at step 1.

    The only solution that worked so far is downgrading to version 2.2

    Kind regard,
    Mohammed Kadhim

    martinjstephens

    (@martinjstephens)

    Thanks Mohammed, I am on 3.0.15 too and still have the same issue. May I ask where/how you obtained the v2.2 files for the plugin?

    KR
    Martin

    Plugin Author SSL Zen

    (@sslzen)

    @martinjstephens @mohammedkadhim
    Thank you for reaching out to us.

    The reason we sometimes ask for cPanel details in free version (3.0.15) is to automatically verify your domain ownership with Let’s Encrypt. Previously, this step was manual and a lot of users struggled with it.

    If you could reach out to us via our website or send a message from the plugin, we would be happy to take a look at the issue.

    @mohammedkadhim hola! una consulta donde consigo la versión 2.2, agradezco amablemente su ayuda.

    The same is happening to me.
    After inserting cPanel credentials and clicking on NEXT, the preloader and black overlay appears but nothing happens.

    @martinjstephens @javier2021

    You can get older versions from here:
    https://wordpress.org/plugins/ssl-zen/advanced/

    • This reply was modified 2 months, 4 weeks ago by walpap.
    • This reply was modified 2 months, 4 weeks ago by walpap.
    Plugin Contributor SSL Zen – Support

    (@sslzensupport)

    Hello @walpap,

    If you could reach out to us via our website or send a message from the plugin, we would be happy to take a look at the issue.

    I had the same problem and downgrading it to 2.2 fixed it.

    @sslzensupport i wish you could have test your plugin better. understand me correctly – your plugin is awesome, it’s just not nice when it suddenly stops working.

    I think I was able to get around this in the end by removing the acme-challenge folder that the plugin had created in File Manager in CPanel and start the process from scratch. The issue arose after I deactivated and reactivated the plugin.

    This was a few weeks ago and there have been some new versions since then, so sorry if this isn’t still a relevant suggestion.

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.