WordPress.org

Support

Support » Plugins and Hacks » Cannot get YouTube videos to work

Cannot get YouTube videos to work

  • Cannot get fancy box for wordpress to play YouTube videos. I have been through this entire support blog with no answers. Can someone pleas epost a working example?

    Here is my non-working one… it just puts the “working” icon up that spins and spins…

    <a href="http://www.youtube.com/embed/kt-sRZ-O6qI?fs=1&autoplay=1&loop=1" class="fancybox"><img src="/images/video-still.jpg" width="192" height="120" border="1"/></a>

    Click it… spinning icon appears… nothing plays.

    Can ANYONE address this? Show an example that works?

    http://wordpress.org/extend/plugins/fancybox-for-wordpress/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Dani-Girl
    Member

    @dani-girl

    Hi looking for a solution as well. I tried the tip found here:

    http://fancybox.net/blog

    but it doesn’t work. the link opens in a new window and causes my other Jquery calls to fail.

    stephlynnmor311
    Member

    @stephlynnmor311

    I’m having the same problem. It pops-up fine but spins and spins.

    stephlynnmor311
    Member

    @stephlynnmor311

    Ah! I figured it out. It was the video URL I was using. I had the embed URL, when I grabbed it from the url bar, that one worked just fine. Hope that helps!

    I tried the suggestion above of adding the url from the url bar and not the embed link, but my working icon is still spinning and spinning. Would you mind providing a copy of the html that made it work for you?

    Here’s what I have:
    <a href="http://www.youtube.com/watch?v=Hjpn9k6Ye0o" class="fancybox"><img src="http://i1.ytimg.com/vi/Hjpn9k6Ye0o/mqdefault.jpg" width="192" height="120" border="1"/></a>

    andy_woz
    Participant

    @andy_woz

    Anyone requiring this try turning on Extra FancyBox Calls (Advanced) and adding the following jQuery call . Then simply assign your href the .video class.

    jQuery(document).ready(function() {
    
    	jQuery(".video").click(function() {
    		jQuery.fancybox({
    			'padding'		: 0,
    			'autoScale'		: false,
    			'transitionIn'	: 'none',
    			'transitionOut'	: 'none',
    			'title'			: this.title,
    			'width'			: 640,
    			'height'		: 385,
    			'href'			: this.href.replace(new RegExp("watch\\?v=", "i"), 'v/'),
    			'type'			: 'swf',
    			'swf'			: {
    			'wmode'				: 'transparent',
    			'allowfullscreen'	: 'true'
    			}
    		});
    
    		return false;
    	});
    });
    sivertsons
    Member

    @sivertsons

    andy_woz, your solution worked perfectly only problem is I can’t figure out how to make this solution responsive. Any suggestions?

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Cannot get YouTube videos to work’ is closed to new replies.