Support » Plugin: WPBook » Cannot get WPBook working properly

  • Resolved chrismillard

    (@chrismillard)


    Hi John,

    After getting WPBook Lite working, I thought I would try WPBook as it appears to have more features that I need.

    Since I don’t have SSL on my blog, I’m using http://fbssl.me to provide a URL.

    I’ve got my app set up on Facebook with the “Website with Facebook Login”, “App on Facebook” and “Page Tab” all configured.

    In WPBook, when I click on the “Checking permissions” link, it takes me to a Facebook page where it shows the following:-

    This page is where you can check and grant extended permissions, which enable WPBook to publish to your personal wall and/or to the walls of fan pages.

    The Facebook profile ID you are currently logged in to Facebook as is . You have defined <my FB used ID was here> as your Facebook user id in WPBook Settings.

    Your Facebook Profile ID must match the ID with which you are logged in to Facebook, or else an access token will not be stored and publishing to Facebook will fail. Please update the “YOUR Facebook Profile ID” setting in WPBook settings to match the userid shown above.

    FB profile has granted these permissions:
    •read_stream – no
    •publish_stream – no
    •manage_pages – no
    •user_groups – no

    An access token for this user has been stored.

    Stored access token is <long access token here>

    Active access token is <long access token here>

    You’ve indicated you wish to publish to this group: <my group id was here>

    ERROR: The user access token does not include publish stream and offline access permissions.

    To correct any of these, Grant or re-grant permissions for your userid. (This is required if you intend to publish to your personal wall OR any fan pages.)

    I click on the link to Grant or re-grant permissions but it doesn’t seem to work for me, and I therefore don’t know how to change the permissions.

    http://wordpress.org/plugins/wpbook/

Viewing 15 replies - 31 through 45 (of 45 total)
  • Plugin Author John Eckman

    (@johneckman)

    Just pushed 2.6.6 which should fix this problem.

    Had to comment out the appsecret_proof the Facebook PHP SDK is sending on calls with an access token – not sure why that is failing.

    See http://www.takwing.idv.hk/blog/2013/be-careful-with-latest-php-sdk-v3-2-2-on-appsecret_proof/ for example.

    We’re not changing the AppID or Secret during the process, so the appsecret should be correct – but it seems like the PHP SDK sends the wrong info.

    Well done, John, and thank you.

    Plugin Author John Eckman

    (@johneckman)

    AKCarlow – does that mean you’ve validated it is working for you?

    I tested it on a page and a group, but would love to hear others having success too.

    Yes, I posted on our WordPress page, and the post was successfully echoed to our facebook page.

    A comment I made to the post in facebook didn’t make its way back to WordPress, at least not yet. Could it be that it is because I haven’t put anything in the associated email address for comments?

    If you were looking for additional features … it would be great if the echoed post in facebook appeared in the name of the WordPress poster, rather than in my name. 🙂

    Plugin Author John Eckman

    (@johneckman)

    Well, that’s a whole different thing. ;p

    That would require storing a different access token per logged in WordPress user – though I guess that wouldn’t be so bad – I could just add it to user_mta instead of storing as a sitewide option:

    http://codex.wordpress.org/Function_Reference/add_user_meta

    Comments cron job runs on the hour

    But how would you get the access token for them? And would they have to be facebook users too?

    BTW, the comment on the facebook page eventually surfaced in WordPress, correctly awaiting moderation.

    I see a change in behaviour …. it used to be that the echoed post in facebook was a link back to the post in WordPress, but now it is just a link to the fb app’s canvas page.

    John, whatever you have done is now working for me too – even with the https://fbssl.me address!!!

    More about that change in behaviour – if group members click on the link in the post in facebook, they get an error “content blocked because it was not signed with a valid security certificate”.

    Is this your problem or mine?

    Plugin Author John Eckman

    (@johneckman)

    AKCarlow – I’d say it is yours, but that may not be fair without more detail.

    Does the canvas page of your app load correctly in Facebook?

    It would be something like https://apps.facebook.com/yourname/ ?

    What do the permalinks for individual posts look like?

    Yes, https://apps.facebook.com/carlowpic/ opens with all the recent posts, including those that did not make it to the group page. The permalink for one that did make it to the group page is http://carlowphoto.ie/he-shall-not-hear-the-bittern-cry on WordPress, but https://apps.facebook.com/carlowpic/he-shall-not-hear-the-bittern-cry on the group page and the canvas page.

    Plugin Author John Eckman

    (@johneckman)

    Not sure if you’ve done some work on this or changed something recently, but I can’t get any pages on your app to load appropriately.

    Visiting https://carlowphoto.ie/ throws an SSL error – unless you can view your blog via SSL, Facebook canvas view will not work.

    Could this be ‘cos we have no SSL cert in place?

    Plugin Author John Eckman

    (@johneckman)

    Yes. You need to have an SSL cert. If you don’t, Facebook will not allow your application to display canvas pages.

    You can set your own Facebook security settings (account settings, security, secure browsing) to allow yourself to browse Facebook in http, without https – and then test your app without https – but you can’t make that choice for anyone else.

    You may need to use WPBook Lite.

    Making progress – slowly. Will a self-signed SSL cert do? There is one now in place.

    Plugin Author John Eckman

    (@johneckman)

    Not sure – I think that will put u a warning and require folks to accept the self-signed cert.

Viewing 15 replies - 31 through 45 (of 45 total)
  • The topic ‘Cannot get WPBook working properly’ is closed to new replies.