Support » Networking WordPress » Cannot get multi-site and multi-domain working

  • Resolved Durnik


    To all,

    I’ve been trying off and on for over 4 days and cannot get a multi-site & domain working. Here’s what I’m attempting to accomplish and where the latest failure is:


    I have two domains <name>.net and <name>.me registered and pointing at the same host. What I’d like is for anyone navigating to <name>.net to see my professional pages and blog. Anyone navigating to <name>.me should get my personal blog and hobbies pages.
    (from hereon, wherever you see name, assume its the domain name)

    WP 3.9.2 is installed on a Linux (Centos 7) VPS along with the latest LAMP stack. So, here’s where I have gotten to and my latest/last stumbling block:

    1) The host file is configured as x.x.x.x
    2) WordPress is installed under /var/www/html/wordpress.
    3) I’ve enabled a test site to act as the default web page using the instructions found on this site (copied index.php and .htaccess into the root folder and modified the index.php). This is working fine as I can navigate to all 4 urls (,,, and all get me to the same test site
    4) Enabled multi-site (pretty urls work, .htaccess updates) and I updated the wp-config.php and .htaccess with the new rules and selected sub-directory site installs (not wildcard DNS)
    5) I added a new site and all went well. The super admin menu lets me see the site, navigate to them, update them. All is well
    6) Installed the mu plugin. Installed from the panel, activated it, copied the sunrise.php to the right place, updated the wp-config.php, went to the network page and defined the ip address and once again no issues.

    Now, here’s where the final hurdle lies:

    I can get into the domain mapping menu and it can only find a single domain (e.g. can be found from the domain search field, but it refuses to show or find,, In addition, the only domain it can find is the domain that breaks access to the admin console on subsequent logout and attempt to login. You can see the re-direct looping and you can never get back into the web admin page

    So, I can map one domain to a default web site (e.g. hover over the edit and select the index) but cannot get the mu-plugin to find or allow me to map any other domain

    Has anyone seen this issue and have any idea of what is going on here?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Can you screenshot what you see on the domain mapping menu?

    I’m assuming you’re looking at Tools->Domain Mapping

    And there you add in the domains you want to map

    Thanks for the offer for help. I can’t figure out how to paste a picture here. However, you’re right, last night it would only find one, now (after I’d reverted and re-did all the steps), it won’t find any.

    Where I am:
    – Two sites defined
    – Plugin installed, sunrise moved and activation put in wp-config.php

    I can see the two sites, navigate from the control panel to each. However, when I go to the super admin, setup the network and then here’s where I’m stuck:

    I go to the “Domain Mapping: Domains” panel. From there you have the option of putting in the domain and hitting a search button. None of the domains I put in there will resolve.

    I tried to manual enter a site below (in the domain and site panels, i.e. 1 and <domain>) and nothing will work.

    I’m stuck. Any help would be appreciated

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    You post a link to the picture:

    Go to /wp-admin/network/settings.php?page=dm_domains_admin

    You should be filling in the add NEW domain bit 🙂


    Thanks for the hint, for the next go round I’ll host the pics somewhere and put the links in here.

    So, once again, thanks so much for your help and assistance so far. Since this is a brand new host, I just went ahead and re-imaged it and I’m rebuilding it from scratch (LAMP, WordPress, Etc) and will try again. This time I’m taking a full snap shot for each step for easy reversal and I’m going to try a root install (e.g. wordpress in the /var/www/html directory) and see if it makes any difference.

    However, the funny thing is that my screen looks nothing like what you have posted in your link (possibly I have a newer version?). What I have on the page is two sections:

    Section 1 allows me to enter a domain and then hit ‘search’.
    Section 2 allows me to assign the domain to a site (numeric entry) along with default as a checkbox.

    So, give me a day to finish rebuilding and trying again and I’ll respond here with success, failures and links to the screen shots

    Once again, I can’t thank you enough for your kind help with this and hopefully this will just ‘work’ this time (or I’ll be losing some more hair)

    My thanks,


    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    I JUST installed the latest version of the plugin on WP 3.9.2 so if you don’t have what I have, then I really need a screenshot because we may not be using the same plugin.

    What I gave you a screenshot of was the bottom half of a page.

    The top have is the search thing, but if you read what that said, it says to search for existing mapped domains. Since you have none, you scroll down to section #2 and add the domain. Which is what I thought you were trying to do…


    that’s exactly what I’m trying to do. I go to the bottom fields and enter any combination of:

    site # (1 or 2, I only have two test sites)

    Domain (I’ve tried <name>.net <name>.me http://www.<name>.me, etc) where <name> is my root that I have for both a .me and .net. Nothing I enter below causes anything to happen when I submit (it just refreshes the screen and no new entries). I tried going to the sites menu to see what the ‘mapping’ fields said and they were blank also.

    In the field above I tried entering any of the same combinations to see if a search would populate something (I’ve seen that in some install screen shots). However, same result. Nothing happens on the page other than a refresh.

    I’m pretty sure we have the same rev of plugin since I just created the original site 5 days ago.

    As I said, I’ve blown the server away and starting from scratch and I’ll update this post with any changes, failures, successes and links to screen shots if it fails again. Note: this time I’m going to install wordpress in the root (/var/www/html) instead of a sub under that as I did last time. I’ve seen conflicting reports on whether the domain plugin does or does not work in that situation.

    Thanks again for the assistance, hopefully it will work or I’ll be able to give you at least some screen shots to give you some idea of where the problem may be (or where I screwed up).

    Bob H


    Haven’t forgotten you. I re-installed and played around and was finally able to get one site to map to a domain. Here’s the latest situation:

    1) Fresh install of wordpress, maria, etc. I installed wordpress in the “/var/www/html” root
    2) Enabled multi-site, permalinks and created a second blog. I had two blogs, one at “/” and one at “/personal”
    3) Installed the domain plugin, moved sunshine, modded wp-config, .htaccess

    Now, I could map both domains to the /personal blog (site #2 in the mapping). However, under no circumstances would it let me map anything to site 1 (“/”). With both sites mapped to the same blog I also received a redirect loop in access (i.e. navigate to “x.x.x” and I get re-directed to “/personal/personal/personal/personal…..”)

    I’m going to re-install one more time and try it and then I think I’m going to take up professional drinking as a new vocation if it doesn’t work

    I’ll update you later today


    I finally have it working. Here’s what finally worked for me and I hope it helps someone else.

    1) Make sure that your host file only has one name in it (e.g. even though I have two domains pointing at this host, I only defined one of them in the hostname & host file)
    2) Install everything exactly as the documents/how-tos explain.
    3) Enable the mu-plugin and only map the 2nd domain (the one not defined in the host file) to the 2nd site I created, NOT the original install created site.
    4) Do NOT try and map the default/1st site to the existing domain/hostname

    Thanks for the offer to help Ipstenu. I struggled with this quite a bit, but your offer for help kept me going

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    However, under no circumstances would it let me map anything to site 1 (“/”).

    Well … yeah. You didn’t say you were trying to map site #1. You’re not supposed to do that ever. WordPress doesn’t really like having two URLs, and the concept is that you put the main site where you want it, not in one place and map it to another.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Cannot get multi-site and multi-domain working’ is closed to new replies.