Support » Fixing WordPress » Cannot get into WP Dashboard

Viewing 8 replies - 1 through 8 (of 8 total)
  • lisa

    (@contentiskey)

    in your webhosting account have you checked in the PHPMYADMIN area to be sure your username has necessary capabilities for administrator in the database table for users?

    gongola

    (@gongola)

    I have tried to check the PHPMyAdmin and I have noticed that under wp_usermeta table, then wp_capabilities I have “a:2:{s:9:”translate”;b:1;s:6:”author”;b:1;}”. Is this supposed to include administrator or rather “a:1:{s:13:”administrator”;b:1;}” ? Thank you.

    lisa

    (@contentiskey)

    do you see any users with administrator capabilities?

    • This reply was modified 5 months ago by  lisa.
    gongola

    (@gongola)

    I am not 100% sure where I can see this, but I do not see “administrator” in wp_capabilities, wp_usermeta or wp_users.

    gongola

    (@gongola)

    I just created a new user with administrator capabilities, but it still does not work. I still get redirected to the homepage when logging in. 🙁

    lisa

    (@contentiskey)

    thanks for confirming that you have setup an new user that has all administrator capabilities.

    what are the settings in the OPTIONS table for “home” and “site URL”?
    do you have an SSL certificate?
    are you using a redirect plugin?

    gongola

    (@gongola)

    Hello.

    For the options I have added

    define( ‘WP_HOME’, ‘http://www.example.com’ );
    define( ‘WP_SITEURL’, ‘http://www.example.com’ );

    I am not using a redirect plugin. Also I do have an SSL certificate, however, it seems to say website not secure on wp-login page.

    I just finished battling a similar situation but I migrated my website to a new hosting so the prefix of my database tables changed.

    In wp_usermeta, there are several meta_keys that start with the old table prefix. You’ll need to update them to the new prefix in order to log in.

    I hope this helps.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.