WordPress.org

Support

Support » Plugins and Hacks » WP Clone by WP Academy » [Resolved] Cannot find "temp" directory during restore

[Resolved] Cannot find "temp" directory during restore

  • Hello, I hope you can help.

    During a restore, it gives me this error: The plugin encountered an error during the restore process,the following error message was returned:
    Error Message : Cannot find /home/username/public_html/wp-content/wpclone-temp/wpclone_backup_09th_Jun_2013_02-08PM_Gen_IAyXj4h9x0

    I try everything I read…. I’ve tried manually installing the wpclone plugin to make sure it’s not permission error. I’ve temporarily changed wp-content to 777 (along with upload and every directory it seems to use) I’ve tried FTP’ing down the zip file from source site, and FTP’ing and changing the link to be the destination site. I’ve tried manually creating this “temp” directory which it cannot find and making this 777

    I have literally 2 weeks of failed clone attempts. It seems that this plugin has some resolved issues – can you resolve mine?

    Scratching my head 🙁

    Thank you in advance for your response,
    Heather

    http://wordpress.org/extend/plugins/wp-clone-by-wp-academy/

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Author WP Academy

    @wpacademy

    download the backup onto your computer and open it,can you see a folder named ‘wpclone_backup’? (everything else should be inside it)
    were you asked to enter FTP details?
    by the way,did you try the ‘alternate zip method’? (you can see it after clicking the ‘advanced settings’ link)

    No, there is actually *not* a folder called wpclone_backup within the zip file.

    *Yes* I’m always asked to enter my FTP details. Once I put that password in, everything works (updates/installs/etc).

    Wow —> I didn’t even see that “advanced link” down there!

    What is your recommendation? I have a good feeling about this 🙂

    I’m going to try the alternate zip method right now…

    Same error with “alternate zip” selected under advanced settings. (By the way, I *only* selected the alternate checkbox and left everything else unchecked)

    Error Message : Cannot find /home/batonrou/public_html/wp-content/wpclone-temp/wpclone_backup_09th_Jun_2013_06-13PM_Gen_JkpQLxRIdH

    This time, I left the zip file where it was, and didn’t change the link.

    Any other ways around this? Why does it keep looking for a folder that doesn’t get generated by zip?

    My apologies, as I mis-read your first question.

    Upon looking in the zip, *yes* there is a folder called wpclone_backup. That root file contains the database (about 3.7mg). Also is another folder, wp-content, which appears to have everything in that as well.

    The backup file is about 100 megs – not too big, I don’t think.

    Any thoughts?

    Plugin Author WP Academy

    @wpacademy

    okay try this,rename the zip file to ‘wpclone_backup’,then place that inside ‘wp-content/uploads/wp-clone/’ and link it from there..
    by the way,could you send your php/apache error logs to support@wpacademy.com?

    You got it. I’ll put (webworks php/apache error logs) in the subject line.

    Stand by –
    Heather

    I am *so* very excited to announce that I got past that error with your suggestion to rename.

    It said “Restore Successful”

    But what’s very strange is, there is no .htaccess file in the public_html directory to make writable (to fix the permalinks). (Usually I type “-a” to see this file in WS-FTP, and I *do* see that the .htaccess file exists in the SOURCE site.

    I then noticed there is no content in wp-content. However, the new content *is* located under /wp-content/wpclone-temp/. I see my gallery directory and everything.

    I don’t mind moving the files, if that’s what fixes it. The htaccess file is puzzling me though.

    Can I just make my own .htaccess file (by pasting what is suggested on the permalinks settings page?

    …..and then perhaps just move the files out of the temp?

    I really hope it’s that simple 🙂

    Plugin Author WP Academy

    @wpacademy

    yeah it doesn’t copy the htaccess file,but WP will create a new one of you re-save the permalinks.
    and,assuming that the database import went well,copying the content from ‘/wpclone-temp/wpclone_backup/wp-content/’ to ‘wp-content’ should do the trick.

    anyhow,this doesn’t make much sense to me,those files should’ve been copied,and even if that failed,the temp directory should’ve been deleted..

    Unfortunately it won’t allow me to move wp-content on the server, so I’m downloading the files manually, and then I’ll replace it that way. (I guess because it’s owned by “99”)

    I see all of the pages, but for whatever reason, I have a blank website (no home page: http://www.batonrougeluxuryapartments.com/). …even after save the permalinks, and created the htaccess.

    If you have any other ideas, please share. I wonder if I should do the restore again.

    Do you have an alternate address? The error logs bounced. I checked and typed it accurately. The attachments are txt and gz.

    Plugin Author WP Academy

    @wpacademy

    probably because the theme is missing,it’ll show up after you’ve moved the files *hopefully*
    by the way,who is the host?

    Plugin Author WP Academy

    @wpacademy

    ah darn it,send them to vidm@live.com

    Here you go – I’ll just delete these when you say. The text is the error log and the gz file is apache log, both from the *destination* site.

    I placed these on the source site, since I’m furiously downloading at the destination at the moment 🙂 http://apartmentprofessionals.com/errors/

    Please check out the top of the error.txt file for additional notes.

    Thank you for reminding me about the theme—I’m relieved to hear that – must have been a duh moment 🙂

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘[Resolved] Cannot find "temp" directory during restore’ is closed to new replies.
Skip to toolbar