Support » Plugin: BuddyPress Links » Cannot find BP-links Admin link BP 1.6 & WPMU 3.5

  • Resolved olekeh001

    (@olekeh001)


    Hello, I installed a fresh WPMU subdomain site at humlesite.com and added latest buddypress 1.6. I then added the buddypress links plugin. I got a message that there was no page for it, with a repair button. I created a page “Links”, and assigned to it. So far all is OK.

    However, there is no sign of the admin interface of the plugin, anywhere in the site. You can add links from the front, but not edit or delete them. I see from some screen shot that there should be a BP-Links admin in the dashboard. How do I get access to this ?

    http://wordpress.org/extend/plugins/buddypress-links/

Viewing 15 replies - 1 through 15 (of 25 total)
  • Plugin Author MrMaz

    (@mrmaz)

    Are you looking at the Network Dashboard? Depending on your setup the Links admin menu might only be showing up on the site dashboard where you activated it.

    I cannot find any dashboard any place. Not in the network, not on the main site. I have tried “network activate”, or deactivated it to just activate on the main site. There is no sign of this panel – it is completely non-existent in every dashboard.

    I am having the same issue, there is no ‘BP Links’ menu to manage links and edit categories. Any resolution known for this?

    Plugin Author MrMaz

    (@mrmaz)

    I am not able to replicate this on my test set up. Here are the versions I am on…

    WordPress 3.5
    BuddyPress 1.6.2
    BP Links 0.7.1

    @mrmaz: I’m on the same versions:
    WordPress Version 3.5
    BuddyPress Version 1.6.2
    BP Links Version 0.7.1
    but have the issue of the BP Links menu not showing. As to be expected I’m also using other plugins like WPML, Wiki etc. Are there any plugins you know that can give conflicts? Any tips on how we can get this fixed?

    Plugin Author MrMaz

    (@mrmaz)

    You can try disabling all plugins, then activate only BP Links. If the menu shows up, then you know its a plugin conflict.

    Those are the exact same versions I have. When I installed a new site, I installed WP asa multisite install from softaculus, then added and activated, Buddypress and BP links in that order. No “BP-Links” admin. I have later on added other plugins to my site, like WPML, etc.

    I have now tried to turn off everything, except buddypress, and BP-links. No “BP-links” admin. I tried to deactivate, and re-activate BP-links. No difference.

    Plugin Author MrMaz

    (@mrmaz)

    I am stumped. I have tried activating it for a specific site, and network wide, and in both cases I can see the menu.

    Is it supposed to appear in the network dashboard, or in the site dashboard for a multisite installation ?

    Plugin Author MrMaz

    (@mrmaz)

    It should show up on the site dashboard of the primary BuddyPress blog.

    I have done some testing here, and found that it actually execute the “bp_links_add_admin_menu()” function on the main site dashboard page. I inserted a print statement in the code to test. It is very strange..

    If there is some I can test to give you some more data, just tell me.
    Ole

    Is there a link I can use to manually enter the admin interface ?

    I also am having this issue, just installing buddypress links for the first time.

    Initially i got the ‘No buddypress page found for this compoenent’ message and the option to repair, but there is no page for links, so i created a blank page with this slug.

    Then i realised there is nothing in the admin panel for it, it doesnt look like its installed at all really.

    3days and no reply? :S i really wanted to give this a try, even the demo is down.

    Plugin Author MrMaz

    (@mrmaz)

    @bitnumus Giving free support for free software on the weekend or on a busy Monday isn’t going to happen very often.

    What I have found out so far is that I *think* the issue is related to the dashboard menu/admin screens require the ‘manage_links’ capability, which anyone who has the editor role or higher should have. Not sure why this is an issue as of 3.5. If anyone has any clues, please lmk.

    Here is the role/cap table:
    http://codex.wordpress.org/Roles_and_Capabilities#Capability_vs._Role_Table

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘Cannot find BP-links Admin link BP 1.6 & WPMU 3.5’ is closed to new replies.