Support » Plugin: W3 Total Cache » Cannot exclude page with infinite scroll ajax on it

  • Resolved Jonas

    (@gnuworld)


    On the whole W3TC has been great but I’ve got a blog post listing page which has infinite scroll functionality on it which I think is Ajax driven.

    Certain posts on the page have glitches like read more links which aren’t hyperlinked anymore and other graphical glitches.

    I’ve narrowed this down to W3TC. If I disable the plugin the page works fine, as soon as I enable it again it doesn’t.

    Am using Disk: Basic caching, Opcode: Zend Opcache, DB Cache and Browser Cache. I am not using W3TC’s minify (use Autoptimize for this) or Object Cache.

    I have tried adding the page in question to both page cache and db cache exclusions in W3TC and this makes absolutely no difference. The issue remains.

    What is W3TC still doing with that page which could continue to cause the issue despite the exclusions?

Viewing 5 replies - 1 through 5 (of 5 total)
  • There is (or was, not sure?) a known issue in W3TC+AO where AO used W3TC’s HTML minifier even if W3TC had HTML minify off (due to W3TC’s being loaded if if HTML minify was off). Maybe try disabling HTML minification in AO to exclude that as a possible reason?

    frank (ao dev)

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @gnuworld

    Can you please try as suggested and see if that resolves the issue?

    @optimizingmatters Excellent catch Frank, thank you very much for jumping in, that indeed looks like it’s the issue. Disabling AO’s HTML minification solves the problem.

    I have wrapped the infinite scroll blog element in noptimize tags and subsequently re-enabled AO’s HTML minification and also removed the caching exclusions which I had set up for the page in W3TC.

    This now works for the page in question.

    It seems to me like W3TC should not be loading its minifier if one has disabled the minification option in W3TC? I’m not sure whether AO’s own minifier would’ve produced the same issue but even if then troubleshooting would involve one rather than two plugins.

    In any event I’m very grateful that you jumped in here and guess perhaps lucky that I mentioned AO in my thread (guessing you got notified of the mention?).

    Will leave you an overdue 5* review on AO.

    the mention, indeed 🙂

    It seems to me like W3TC should not be loading its minifier if one has disabled the minification option in W3TC? I’m not sure whether AO’s own minifier would’ve produced the same issue

    it should not and it would not have no.

    @vmarko any news from the developers on when this would be solved Marko?

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @optimizingmatters and @gnuworld

    Thank you for your feedback.
    I spoke with the team and we will be pushing this. It should be fixed in future releases.
    Thank you for your patience!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Cannot exclude page with infinite scroll ajax on it’ is closed to new replies.