Support » Plugins and Hacks » [Resolved] Cannot enter settings pages

[Resolved] Cannot enter settings pages

  • Hey man,

    I cannot seem to figure out how to get in the plugin settings… i tried to acces it trough the plugin menu, but it says that i don’t have enough permissions to do that… bit weird since my account is administrator.

    I need them to convert the date format to a more logic one (ex. 30/01/2013/), since i’m using the post expiration date as a feed for my countdown timer 😉

    I’ve already tried the beta 2.0, but it doesn’t seem to fix my bug… :s

    Thanks for your support and your great plugin!


    Stephen Bouckaert


Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Aaron Axelsen


    There is a “Post Expirator” menu item under settings.

    Hi man,

    Thanks for the fast reply, then it must be a bug of some sort i’m having…

    Since in my settings i cannot see any “Post Expirator” menu, i’ve fixed the date issue by converting it in PHP to the format for my countdown timer (pic: http://grab.by/ksDe ).

    Only bug i found in version 2.0 was if i set the time on 9am for example on submit it changed it to 10am, always one hour later then i selected. Also yesterday it auto set the timer on submit whatever hour i entered to 9pm, but i cannot duplicate it 🙁

    I’ve implemented the 2.0 beta version right now, because i couldn’t set “set to draft” in the 1.x.x version (since i cannot acces settings menu), i’ll update it when it goes live 😉

    Keep up the good work!



    Plugin Author Aaron Axelsen


    What happens if you try loading this URL directly? /wp-admin/options-general.php?page=post-expirator.php

    As for the timezone – I spent alot of time testing configurations and DST settings, so I’m surprised your seeing this. What is your wordpress and server/php timezone set to?

    This happens: http://grab.by/ksTU it says: ‘You don’t have suficient permissions to acces this page’, i’m on the administrator account…

    La hora UTC es 06-03-2013 12:40 La hora local es 06-03-2013 13:40

    It’s set on Madrid timezone

    The time bug only occurs on 2.0, it works just fine on 1.6 😉

    Plugin Author Aaron Axelsen


    You must be running multisite – I just made a change in the dev version that fixes the setting screen.

    Do you actually know what the server time is? Are you hosting your own or using a provider? The above is just what wordpress is reporting.

    It works! I can enter the settings now 😉

    The server is local so the timesettings are:

    date/time support enabled
    “Olson” Timezone Database Version 2012.10
    Timezone Database internal
    Default timezone Europe/Stockholm

    Directive Local Value Master Value
    date.default_latitude 31.7667 31.7667
    date.default_longitude 35.2333 35.2333
    date.sunrise_zenith 90.583333 90.583333
    date.sunset_zenith 90.583333 90.583333
    date.timezone Europe/Berlin Europe/Berlin

    It think the bug occurs when submiting the form it does +1 on the hour 😉

    Thanks for all the help!


    Plugin Author Aaron Axelsen


    I’m having trouble trying to reproduce this issue. Can you give me an exact example of when this happens? The exact date/time/etc that you are using to set the expired post?

    I used the date of yesterday, and 10 o’clock in the morning as hour 🙂

    Plugin Author Aaron Axelsen


    I tried replicating this with your timezones and times on my dev server, but i can’t get the issue to reappear :/ .. are you testing on a development system or is there any way I could see this on your system?

    Hey man,

    Sorry, can’t grand you acces to the server, due to it’s a commercial project and i’m just an intern, and they won’t let me put the project on my own server for testing purposes :p

    I’m using atm Mamp as local server… so maybe that’s it.

    I’ve installed a version of WordPress on my server and configured your plugin and i cannot seem to duplicate it…

    So it’s maybe localhost related, if they give me green light to deploy everything on their servers, then i’ll test it over there 🙂 as of now i’ll consider this case solved.

    Plugin Author Aaron Axelsen


    Fair enough – works for me!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] Cannot enter settings pages’ is closed to new replies.