Support » Plugin: Redis Object Cache » Cannot enable Redis object

  • Resolved ideje

    (@ideje)


    HI!

    I get the message: Object cache could not be enabled.
    Overview
    Status: Drop-in is invalid
    Drop-in: Invalid
    Filesystem: Writeable

    Status: Drop-in is invalid
    Client: 
    Drop-in: Invalid
    Disabled: No
    PhpRedis: 5.1.1
    Predis: Not loaded
    Credis: Not loaded
    PHP Version: 7.4.3
    Plugin Version: 2.0.22
    Redis Version: Unknown
    Multisite: No
    Metrics: Disabled
    Metrics recorded: null
    Filesystem: Could not initialize filesystem.
    Drop-ins: [
        "object-cache.php v by "
    ]

    Object Cache
    Persistent object cache plugin not in use
    The Redis object cache extension for PHP is installed but is not in use by WordPress. You should install a Redis plugin

    What I need to do?

    Kind, Daniel

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Till Krüss

    (@tillkruess)

    You WordPress site doesn’t have proper filesystem permissions.

    Could not initialize filesystem.

    You’ll need to fix that before using this plugin.

    Changing File Permissions

    Thread Starter ideje

    (@ideje)

    Thanx Till,

    All I had to do was copy the object-cache.php file to the wp-content folder.

    The next problem I have is the following. I have several websites on VPS. When I install the Redis plugin on the second web page, it shows me cached objects on all sides from the first page. What settings do I need to change for each website to display its cached objects?

    define( ‘WP_REDIS_DATABASE’, 0 ); or something else?

    Kind, Daniel

    Plugin Author Till Krüss

    (@tillkruess)

    Yes, change the database for each site.

    Thread Starter ideje

    (@ideje)

    Hi Till,

    I have successfully set up Redis Object Cache on 14 websites, each with its own database number (1 to 14). On the fifteenth website and the and all others, even if I set a different database number, it no longer works and behaves as if the database number is 0.

    What is going wrong?

    Kind Daniel

    Plugin Author Till Krüss

    (@tillkruess)

    Redis databases are numbered from 0 to 15 by default.

    Each site must have it’s own number.

    After changing the configuration, run FLUSHALL on your Redis Server to make sure no old data is messing things up.

    Thread Starter ideje

    (@ideje)

    Hi Till,

    I have 25-30 pages on VPS server. If I understand correctly, I cannot use the plugin on all websites because i’m limited to number 15 of redis database, or?

    Is there any solution to use redis plugin on all websites?

    Kind Daniel

    Plugin Author Till Krüss

    (@tillkruess)

    You can bump the databases size in your redis.conf.

    Thread Starter ideje

    (@ideje)

    Thanks Till,

    now is ok supposed.

    Best regards

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.