Support » Fixing WordPress » Cannot edit theme on version 2.8

  • Hi guys,

    For some reason, after doing an automatic upgrade to 2.8 one of my sites is no longer able to edit individual theme files.

    It’s very weird actually, when I press save it looks like everything is fine, and if I refresh the editor page the changes I made remain.

    However, if I view the site or download the .php file I edited, the changes are not there.

    It’s like WP is holding a cached page that never gets written to the actual .php file, but whenever you try and edit the file the changes you made are still there.

    Tried disabling code highlighting, didn’t help. Tried on both Firefox and IE, same problem on both.

    Can’t work it out 😛

    FYI, this is on a linux apache host, on my home windows IIS machine it works perfectly.

Viewing 10 replies - 1 through 10 (of 10 total)
  • I’m having all kinds of problems with 2.8, Tirion. Only good news is…so is everyone else. lol

    I can’t get WP Polls Widget to upgrade, which is one of the minor problems. The weird thing is…after I deactivated it, it’s still functioning on my blog. Go figure!

    Only good news is…so is everyone else. lol

    i think i am one of them. lol
    I have same problem, cannot edit theme

    same problem here
    😐

    Thread Starter Tirion

    (@tirion)

    I don’t suppose anyone has found a fix or workaround for this yet? 🙂

    Other than editing locally and FTPing the files of course…

    A whole day has gone by without anyone getting an answer for this problem????

    FYI, this is on a linux apache host, on my home windows IIS machine it works perfectly.

    Makes it sound like this could be server related. Anyone know if their hosting provider is running HyperDB and whether it’s been updated recently?

    I’m having similar problems myself where the theme files load in the editor… and then trying to scroll up or down makes my browser suddenly lock up. I love how the new editor is like a more standard code editor, but this lag and drag and freeze is getting old really fast. :/

    Fixed Now, you need to disable javascript when editing the file and for fast switching to enable/disable javascript use firefox addon WebDeveloper.

    I used WebDeveloper in Firefox, disabled all javscript. It didn’t help a bit.

    Now what?

    @rocketllama
    before you try my trick, you need to chmod your theme file to 666 or 777.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Cannot edit theme on version 2.8’ is closed to new replies.