Support » Plugin: WooCommerce » Cannot Edit Product

  • Resolved manek43509

    (@manek43509)


    I cannot edit product details, because the visual editor is totally blank. This is the case whether I have the Classic Editor plugin activated or not. Please tell me how this can be useable again.

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Support maykato

    (@maykato)

    Hello,

    This kind of problem is usually caused by a conflict with your theme or with another plugin. The best way to determine this is to:

    • Temporarily switch your theme to Storefront
    • Disable all plugins except for WooCommerce
    • Test to see if the issue has been resolved

    If you’re not seeing the same problem after completing the conflict test, then you know the problem was with the plugins and/or theme you deactivated. To figure out which plugin is causing the problem, reactivate your other plugins one by one, testing after each, until you find the one causing conflict. You can find a more detailed explanation on how to do a conflict test here.

    Thread Starter manek43509

    (@manek43509)

    Not convinced about that. It’s an issue I have noticed across multiple different WordPress installs, using different themes, etc. Seems very common that the Visual Editor breaks of its own accord after updating WordPress beyond 5.6 or thereabouts.

    I have tried deactivating as much as I can (some plugins are network active on a Multisite network, and I don’t want to trash functionality on all my sites). Still no good.

    Plugin Support Joey – a11n

    (@jricketts4)

    Can you send us a screenshot of what you’re seeing? I recommend https://snipboard.io for sharing screenshots – please follow the instructions on the page, then paste the URL in this thread. It works with Chrome, Firefox, Safari, and Edge.

    Also, if you inspect the page when this happens, do you see any errors in the ‘Console’? Can you send us a screenshot of that console as well?

    Thread Starter manek43509

    (@manek43509)

    This is what I see when I try to edit a product or add a new product: https://www.manek.org.uk/wp-content/uploads/2021/04/Screenshot-2021-04-30-at-16.01.34.png

    Plugin Support Shohan Hossain Nabil – a11n

    (@sohanhossain)

    Hello @manek43509,

    I’ve performed some cross-testing for us today on several of my sites which have the latest versions of WordPress, WooCommerce, and our free Storefront theme as the only enabled software. When doing so I’ve not been able to replicate the behaviour which you described.

    If you can replicate this in an environment where WordPress, WooCommerce, and Storefront theme as the only enabled software then please create an issue here.

    Thanks!

    Thread Starter manek43509

    (@manek43509)

    Once again, I am not going to trash the functionality of five or more separate websites just to go chasing this gremlin, which is already a well-documented issue with the TinyMCE editor above a certain version of WordPress. (You can see here that this is a very common complaint.)

    Plugin Support Shohan Hossain Nabil – a11n

    (@sohanhossain)

    Hello @manek43509,

    I can totally understand that but there’s nothing much we can do if we are unable to reproduce the exact behavior. I have gone through most of the threads that I found under the search query link you provided and most of them were related to a plugin conflict.

    If you still feel this is something that requires the developer’s attention then please create an issue here.

    Thanks!

    Plugin Support AJ a11n

    (@amandasjackson)

    We haven’t heard back from you in a while, so I’m going to mark this as resolved – if you have any further questions, you can start a new thread.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.