WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Cannot edit posts/add new posts or pages – JS not working correctly

[Resolved] Cannot edit posts/add new posts or pages – JS not working correctly

  • HI all,

    I had WP 3.1 and even at that version, when I logged in to admin area, I saw that form fields looked somehow different.

    When I go to edit post/page or add new post/page, I see blank text area and can’t do anything with it.

    I upgraded WP to the latest 3.3.2 and same thing happens. I am using RedLine theme (heavily customized). I tried switching to default WP theme and same thing happens.

    Also menus on the left inside admin area do not collapse. It is obvious to me that the problem has something to do with JavaScript not loading properly.

    Does anyone have solution to this problem?

    Thanks!

Viewing 7 replies - 1 through 7 (of 7 total)
  • It sounds like there is definitely a conflict with javascript (Which you mentioned). Try disabling all plugins. If the menu’s return to normal, start reactivating one by one until it breaks. Whichever you activated before it broke is your issue.

    If that doesn’t work, there may be something your theme is loading into the admin that is breaking it as well. Try activating the twentyeleven theme and see if it works. If it does, you’ll need to find the javascript in your theme thats breaking it.

    I disabled all plugins – still the same.

    I changed theme to default one – still the same.

    What browser and operating system are you using? For example, are you using Windows Vista and Internet Explorer 8? Can you test on another browser/computer?

    I found the solution, I had to add this line to wp-config.php:

    define('CONCATENATE_SCRIPTS', false);

    So that scripts wouldn’t be loaded via load-scripts.php but each one separately.

    Thanks!

    Fantastic, glad to see you got it fixed!

    Remember to mark your topic “Resolved”.

    kx1, I have been trying to fix this for the past 4 hours. thank you very much it worked.

    What does that do and how did you discover it?

    Amaraa
    Member

    @easyidea

    wp-admin/update-core.php re-install its working for me

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Cannot edit posts/add new posts or pages – JS not working correctly’ is closed to new replies.