Support » Plugin: Min and Max Purchase for WooCommerce » Cannot edit posts or pages with this plugin active

  • Resolved Patrick Mackaaij

    (@mackaaij)


    Hi,

    I cannot save edited posts nor pages anymore with the plugin “Plugin: Min and Max Purchase for WooCommerce” active.

    My error log reads entries like:

    [lsapi:error] [pid 2433303:tid 140236613064448] [client xxx.xxx.xxx.xxx:64864] [host http://www.hostname.nl] Backend fatal error: PHP Fatal error: Uncaught Error: Call to a member function get_cart() on null in /home/xxxxxxxx/domains/hostname.nl/public_html/wp-content/plugins/min-and-max-purchase-for-woocommerce/woo-integration/vtmam-parent-cart-validation.php:93\nStack trace:\n#0 /home/xxxxxxxx/domains/hostname.nl/public_html/wp-includes/class-wp-hook.php(286): VTMAM_Parent_Cart_Validation->vtmam_woo_apply_checkout_cntl(”)\n#1 /home/xxxxxxxx/domains/hostname.nl/public_html/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array)\n#2 /home/xxxxxxxx/domains/hostname.nl/public_html/wp-includes/plugin.php(465): WP_Hook->do_action(Array)\n#3 /home/xxxxxxxx/domains/hostname.nl/public_html/wp-settings.php(526): do_action(‘wp_loaded’)\n#4 /home/xxxxxxxx/domains/hostname.nl/public_html/wp-config.php(85): require_once(‘/home/xxxxxxxx…’)\n#5 /home/xxxxxxxx/domains/hostname.nl/public_html/wp-load.php(37): require_once(‘/home/xxxxxxxx…’)\n#6 /home/xxxxxxxx/domains/hostname.nl/public_html/wp-blog-header.php(13): in /home/deb45029n2/domains/hostname.nl/public_html/wp-content/plugins/min-and-max-purchase-for-woocommerce/woo-integration/vtmam-parent-cart-validation.php on line 93\n, referer: https://www.hostname.nl/wp-admin/post.php?post=15204&action=edit

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author vark

    (@vark)

    Hi,
    I can’t replicate the issue in my test environment….

    Please contact me on my support channel
    https://www.varktech.com/support/

    and send me your System Report:
    – Go into wp-admin, select Woocommerce->System Status .
    – Click button ‘Get System Report’ at top of page.
    – Click button ‘Copy for Support’.
    – Copy the result as instructed on the page
    – Paste into return email to me.

    Best,
    Vark

    Plugin Author vark

    (@vark)

    Hi,
    I’ve created a new version I believe will solve the issue.

    Please drop me a line on my support channel and I’ll send you a google download.

    Best,
    Vark

    Thanks for the quick reply. I filed ticket #862186 in your support system. As you think you resolved the issue, I didn’t add the details you requested earlier.

    Plugin Author vark

    (@vark)

    Hi,
    Thanks for your help with this. New Version: 1.08.2.5 repairs this issue.
    Best,
    Vark

    Glad to help out, thanks for the quick fix!

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.