Support » Fixing WordPress » cannot edit posts or pages after upgrade from 2.3.2

  • Resolved whoojemaflip



    I’m on a shared hosting account, and was happily using wp 2.3.2 for some time before deciding to upgrade initially to 2.3.3 then 2.5 RC2.

    After the upgrade, everything looked fine initially after upgrading the database. The problem occurs whenever I try to save edits to a post that was created before the upgrade.

    Instead of saving the changes, I am quickly redirected to the server root page which as it’s a shared host is not even under my control.

    I’ve tried adding definitions to wp_config to control wp_siteurl and wp_home but to no use.

    Anyone help me?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi, Wooo,
    I don’t have your solution, and I don’t have your exact problem eithers. I can tell you that with my new WP 2.3.3 install that I have much trouble trying to save my first (relatively) large post with tables and a “contact” form.
    In fact, the save is currently locked out. I waited all night for it to update. But, no.
    I can take the same code on this page that won’t save to another new page, and in a new browser and it saves. There is definately an issue with the SAVE EDIT processing. This is horrifying for somebody relying on WP and their main business tool.
    You can probably say the WP has become unstable.
    My first experience with WP has been a time consuming disapointment.
    I hope you resolve your issue.

    In case anyone else comes across this problem in the future, it’s been resolved and it was nothing to do with the wordpress upgrade, and everything to do with my shared host enabling mod_security.

    What fixed it for me was disabling mod_security in .htaccess by adding the following lines.

    <IfModule mod_security.c>
      SecFilterEngine Off
      SecFilterScanPOST Off

    It would be better, I think, to disable mod_security for only the files that are affected, in this case I suspect it is ajax_update.php but until I find the time to get into it in more detail I can’t be sure.

    Does this go in the root of the wp-admin directory or the site root or both?

    blogpire –

    On your DreamHosted site, you can do it from your control panel (just deselect “Extra Web Security” (which is mod_security) for your domain from the Manage Domains screen (click “Edit” under the “Web Hosting” column for your domain).

    If you want to do it manually, you can do it as per above – put that in the .htaccess file in the “base” directory of your domain (so that it will affect all directories beneath that one in the filesystem tree).


    This was fixed by the amazing dreamhost customer support – we were hacked. We did do the upgrade on the hacked database to 2.5 – but they replaced the database with 2.2 and then even ran the upgrade scripts for us and everything is great.

    I guess stay current or get hacked. Also – keep a copy of your database every week – and know that rolling back the database prior to being hacked was the only way to fix this.

    On Thu, 17 Apr 2008, you wrote:
    > This started as:
    > 1. 3 Days ago our PAGES became POSTS
    > 2. We then checked the database and the PAGES are POSTS not PAGES
    > 3. We then upgraded – and the PERMALINKS Updated the PAGE URLS to point to
    > POSTS because I think it’s just a feature of the rewrite
    > 4. Now we can no longer POST PAGES or POST POSTS (we could also not do this
    > with the one click install of 2.2)
    > 5. we are on 2.5 – and before a few days ago had over a year of smooth
    > sailing.
    > Here is a discussion of the same issue with another person at Dreamhost:
    > Attempting to publish a PAGE or POST results ina blank post.php – we do get
    > the title saved but nothing else. The PAGE or POST never publishes to the
    > site and stays in draft mode.
    > This started 3 days ago – when we were still using 2.2 – but then all of our
    > PAGES became POSTS and then you couldn’t post anything. So we upgraded to 2.5
    > and it did fix the permalinks of the old pages that are now POSTS.
    > I have tried the following:
    > 1. Upgrading 2.2 – 2.5
    > 2. Creating a new admin user in 2.5 and seeing if it’s a user permissions
    > problem
    > 3. turning off mod_security for test in the htaccess file
    > 4. updated all plugins
    > 5.deleted cache
    > 6. updated permalinks (which also resulted in a blank page)
    > 7. deleted old htaccess file in route and updated with permalinks
    > 8. Done clean install by deleting everything – then installing plug-ins –
    > etc. and using default theme
    > Nothing fixes it. To me it seems since it happened with 2.2 and our plug-ins,
    > ability to publish posts or pages, and our PAGES turning to POSTS just
    > happened 3 days ago with us changing nothing – something else has to be going
    > on – server side or with some user permissions – database permissions – who
    > knows – but we can’t seem to fix what worked for over a year.

    Hi Jay,

    So I’ve looked at your issue and you seem to have fallen prey to a really
    mean hack attempt that mucks up your database. You did the right thing
    by upgrading to a stable version of WordPress, but now I’ll need to roll
    back your database to its state from 3 days ago to fix this. Go ahead
    and let me know if you are okay with me doing that and I’ll gladly go in
    and take care of you as quickly as possible.


    It’s great that you got things sorted out!

    I also think it was really great of DreamHost technician “Jason” to offer to do that for you. That’s really all about going “above and beyond” for a tech support staffer at a “low-cost” web host, and *that* Rocks!


Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘cannot edit posts or pages after upgrade from 2.3.2’ is closed to new replies.