Support » Fixing WordPress » Cannot edit or remove test & RSS widgets

  • Resolved mel77


    This is a brand new install of the latest WordPress I am testing using XAMPP on my computer.

    In the admin Control panel > Design > Widgets, when you attempt to edit the text and RSS widgets, only half of the edit function box is visible. The left half including the change and remove buttons are not visible. If you left click on the blue heading bar you can grab the box and move it around and everything is visible. As soon as you let it go it jumps back into place and only the right half of the box is visible again.

    What can be done to resolve this? Is this a bug?

Viewing 9 replies - 1 through 9 (of 9 total)
  • This is getting quite a popular problem, has been posted a few times but no answers as yet…. –

    OK this fixed it for me.

    Find: wp-admin/js/widjets.js

    Find line 20 which looks like this:
    li.css( 'marginLeft', ( width - 250 ) * -1 );

    Change the figure 1 on the end to a 0 so the line now looks like this;
    li.css( 'marginLeft', ( width - 250 ) * -0 );

    I notice also in the file there is a comment which says “// it seems IE chokes on these animations because of the positioning/floating

    Does this mean the WordPress people have released this knowing there will be problems with IE?

    Also I wonder about support here… I have been using WordPress for a week. Over the years I have used Mambo, osCommerce and vBulletin where the support forums are answered and issues attended to usually within 24 hours by the developers and qualified moderators. Here there appears to be no support by such people.

    tks for this,
    i will try fix my install…
    all the best
    joao barroca
    aka beduino

    mel77 – thanks, your suggestions worked.

    This happens to me too in IE7, but not in Firefox!


    Does this mean the WordPress people have released this knowing there will be problems with IE?

    Hahaha, “browse happy”.

    I made the change. The result is different from what was intended, but it works. For you who are curious: the modification field of the widget is now just so small that it fits in the part where widgets can be changed, so nothing falls off anymore. The content of the widget becomes a bit messy with these short lines, but it works, so…

    I just upgraded to WP2.5.1 and hoped that the “widget fixes” that were announced would fix the problem, but it hasn’t. I’ve tried EVERY fix listed in the forums for the widget page and NOTHING has worked.

    I use IE7 and MySql is the most current. I also tried this in Opera 9 and it didn’t work.

    When I attempt to add a TEXT widget (which supposedly now I should have as many as I want), I click “Add” and it puts the blue “Text” widget box under the Sidebar listing on the right. But when I click to enter my text, the box disappears completely as though I never tried to add it. VERY frustrating and I had hoped this issue would be fixed with the latest upgrade.

    Apparently not.

    I’m running WP 2.5.1 and it worked for me, in a roundabout sort of way. My primary browser is Firefox, now at v, which has started to misbehave. I tried the fix above, editing the wp-admin/js/widgets.js file, but after line 20 I also edited line 35 in the same manner.

    When I reloaded the same page in Firefox, the problem was still there. I had too many tabs open and didn’t want to close Firefox for a cache clearing, so I fired up my Safari (for windows) and accessed my blog admin from there. Lo and behold, i could now see the edit link for the RSS widget that I could not edit and remove.

    Moral of the story is (for me anyway) always have more than one browser installed on your computer. I have seven (since i’m a web developer and cross-browser compatibility is part of every website we design). What seven you ask? Firefox, IE7, Flock, Safari, Netscape, Opera and Lynx.

    Thanks Mel77, it worked for me!!
    Great job…. keep it up

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Cannot edit or remove test & RSS widgets’ is closed to new replies.