Support » Fixing WordPress » Cannot edit or add new posts since 2.3 upgrade

  • Resolved ColinJason



    I just upgraded my WordPress installation from 2.2.1, to 2.3, and since doing it, I cannot seem to add more than one post, either as a draft, or as a published entry. The trick is, once this single post is created, I cannot edit it at all.

    When I create a post in the editor, and save it as a draft, it appears above the editor in the “Your Drafts:” area, as a link, but when you click that link to presumably edit the posting, this error comes up;

    “You attempted to edit a post that doesn’t exist. Perhaps it was deleted?”

    I try clicking on ‘edit’ within the ‘Manage’ area, and I get the same error.

    Now, with this one post saved as a draft, I cannot create any new posts. You type everything in, hit the save, save & continue editing, or publish buttons, and it just clears the editor fields, without saving anything.

    If I go into the ‘Manage’ area, and delete the draft that I cannot edit, and then go into the editor again to make a new post, it will save that, but we go into the same problem again; I cannot edit it, or make another post.

    One thing I’m noticing is that it’s always giving this single post the same ID, 0. All of my other older entries all have numbers higher than 0. Is there some kind of script or database error in 2.3 that I don’t know about? I followed the detailed upgrade instructions step by step, and ran the upgrade.php script. It updated my database successfully, so it said, but now my install seems dead in the water.

    Now, I *can* edit any of my entries created before the upgrade without problems. It’s just that it won’t create any more than one new entry, which I then cannot edit, and it stops me from creating any other entries after that one is created. I’m just stumped!


Viewing 15 replies - 1 through 15 (of 16 total)
  • Me neither. And from what it looks like, this is effecting more people than just us. Why won’t the Word Press tech team address this issue or, god forbid, offer some assistance?!?!?

    Well! I’m glad I’m not the only one having this issue! I just decided to give up on it for a while, and see if someone in the community knew something. I upgraded without realizing how new the upgrade was. LOL

    Lesson learned.

    Thankfully, if I have to do a fresh install to get my site working again, it won’t be a total wash, since I only had a few posts in it before the upgrade attempt. Still though, it’s frustrating when you go over all the steps VERY carefully, and weirdness like this occurs.

    One thing I’m noticing is that it’s always giving this single post the same ID, 0.

    This might be the key to it! Normally, any new entry should increment the ID – so, my suspicion is something happened during the upgrade with that DB table.
    Let’s hope some knowledgeable coders will offer a solution for it.

    The ID field in wp_posts is supposed to be auto incrementing. That field is also the Primary key for wp_posts.

    Is that what you see in phpMyAdmin for wp_posts?

    I’m looking over my attributes for the wp_posts field, and the ID area doesn’t say ‘auto_increment’ anywhere on it. I’m going to try changing that, and see what happens.

    That fixed it! Thanks MichealH!

    My ID field was set as primary, but in the ‘extras’ area, auto_increment was not set. Once I set that, things started working as they should. 🙂

    Hopefully this will help others!

    Now, the question is, was this a fault of the upgrade.php script?

    It sounds like you guys are finding a solution here, which is great – but the info here is a little over my head. Where is the wp_posts field? Where is the ‘auto_increment’ field supposed to be in there? If anyone could email me the code for what this page is supposed to look like it would be much appreciated. Thanks!

    They are talking about the MySQL database – not about files.
    The database (DB) can be accessed by phpMyadmin – see the link above.

    I found ANOTHER area where the auto_increment setting is also causing problems; comments. I had a comment that I needed to delete, and when I tried to, WordPress threw an error. I looked at the link when hovering over the ‘edit’ link, and lo and behold, it’s ID was also set to 0.

    I’m definitely thinking that the upgrade.php script has issues!!

    I’m going to check over the other fields, and see if this is a trend.

    Ok, here’s a list of problems I’ve found thus far, all related to the same issue with the posts. It seems that when my database was upgraded, the ‘auto_increment’ value was dropped off SEVERAL fields. I’ve spent about the last hour, checking functionality to see where other problems appeared.

    HOPEFULLY I’ve fixed all I need to, but this worries me about future upgrades to be sure. Anyway, here’s a list of what I had to fix in my database;

    wp_posts: added ‘auto_increment’ to ‘ID’ field

    wp_comments: added ‘auto_increment’ to ‘comment_ID’ field

    wp_links: added ‘auto_increment’ to ‘link_id’ field

    wp_users: added ‘auto_increment’ to ‘ID’ field

    wp_usermeta: added ‘auto_increment’ to ‘umeta_id’ field

    If anyone knows of any other tweaks needed, please let me know! I’m not sure what the wp_postmeta area is for, but there’s no information in that area in my database, so I’ve not made any adjustments there. The adjustments I made above was to get Categories, Posts, Comments, Blogroll, Users & their data working properly again after the upgrade.

    This will teach me to fully backup my database next time!

    wp_postmeta: added ‘auto_increment’ to ‘meta_id’ field

    affects editing older pages.

    I can’t type more than one new message in the blog entry box.

    Write / Post /

    1) I CAN type in the title
    2) I CANNOT type the entry in the entry box.

    IF I reboot and start over I CAN type *just one* entry and then it starts over again.

    If we are all having the same or similar problems why can’t anyone help.

    I too upgraded. Followed all the directions. Everything seemed to work until this.

    I upgraded from 2.1 I believe to version 2.3. (I know I chose the right instructions and files)

    Does 2.3.1 fix any of this?

    Please help. I have too much to just dump!


    I’ve tried adding “auto_increment” to the fields mentioned above, and I get this error:

    #1062 – Duplicate entry ‘1’ for key 1

    I don’t know enough about MySQL to know what to do with this.

    Also, the weird thing is, I get the errors when hitting the “Publish” button, but the post gets published anyway.


    I haven’t done an upgrade, but I just installed version 2.3.1. This was giving the same errors from start. So this problem does not only affect updates.

    After changing all ID-fields ColinJason said I still had the same problem when I wanted to add tags. I was able to resolve this by also changing the ID-fields of all other tables to ‘auto_increment’ (I guess they should be) and the problem was fixed.

    Is this problem known by the developers of WordPress?



Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Cannot edit or add new posts since 2.3 upgrade’ is closed to new replies.