Support » Fixing WordPress » Cannot Edit One Specific Page

  • There is one page that I am unable to edit on my wordpress site. I manage the site for my employer and the page that isn’t working is the “Schedule” page, which needs to be altered and upated very often. I have checked every other page,they all work fine and I’m able to edit. However, when I try to edit the Schedule page a blank screen appears with only the words, “Edit Page” in the upper left hand corner. No field to edit html, nothing. Only the published status box on the right. I scrolled through the forums but didn’t find anything that worked. Please help! I am sort of freaking out . . .

Viewing 9 replies - 1 through 9 (of 9 total)
  • That’s nasty. Impossible to see without knowing more. A geek might be required. I have something to check, though. I’m guessing you have bad code in your page (non-html, etc.)

    I was going to say try duplicating the Page and seeing if you can edit that, but that’s my other system, MODx. 🙂

    Quickest idea: make a new page with the same content. If the new page is good, kill the first one, and rename the new one to replace it. btw, don’t directly paste from Word or similar things, use the “Paste from Word” button for stuff like that. Beyond that….

    I had a client who would paste God-only-knows what kind of stuff from Word, silly ad site code, or wherever. When you paste directly from Word, without using the helpful “Paste from Word” button, you get all kinds of nasty extra code in your post. In his case, it killed his site.

    I would suggest going into the database itself, via PHPAdmin or whatever database interface your host has. The table you’ll be looking for is WP_POSTS, and you’ll need to hunt down the offending one and look at the post_content. If it’s full of weird crap, you might want to save that, then delete it in the database so the page will be clean for editing.

    I’m guessing they never gave you a host log-in, and the above might all be gibberish. In that case, geek definitely required. That’s my best guess.

    Maybe someone else will have an idea.

    Good luck, Dave

    Thanks, Dave! I will definitely take a look into database and see if there’s weird stuff in there.

    I’ve started on making a new page as you suggest but have to test it and figure out how to kill the other one (?)

    As a temporary fix, I’ve been able to edit the page fine with WordPress for Android (savde my life today!), it just takes a bit longer.

    I do find it strange that the page in question has full functionality through the app but not through my desktop, no?

    That is crazy, being able to edit, but not in the Dashboard! I wonder if one of your plugins is borking the admin somehow. That’s an odd combo of circumstances.

    And yeah, I suppose it’s hard to delete the other one when you can’t bring it up. If you bring up your list of Pages and hold your mouse (or whatever pointer you’re using) over the bogus page, you should be able to “Trash” it without going in to edit.

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    I wonder if one of your plugins is borking the admin somehow. That’s an odd combo of circumstances.

    That’s most likely the culprit.

    Note: When you trash it, you’ll need to empty the trash before you can re-use the page name.

    Thanks for all the help! I got rid of old page, copied page from my phone and made new page. It looks identical and is working, so thanks!

    I am having the same problem. The page is my bookshelf ( and this morning when I tried to edit it it I got the blank sheet with edit in the top box. Disabled the only two plugins I had running and could edit for a while, but now it’s happened again. Can edit all other pages no problem, but really don’t want to have to recreate the whole thing again.

    The page is just a series of images with html links to other child pages (one for each book). Please, please, any ideas? I’ve tried disabling all plugins but nothing.

    Forgot to add that I edited the original page to recreate it and didn’t create another. Should I have? Saw somewhere that it may still have leftover links to a plugin I’ve deactivated – how would I know this. And if I have to start again, how can I do a safe copy?

    Also, read somewhere else that when updating should press CTRL F5 – which I never do – have I done something dumb?

    Yikes. This has happened to me twice now and it is so befuddling and a total bummer.

    Do you happen to have the Quickpress app on your phone?

    One quick fix I’ve found is copying the html from the page on my phone (which always works oddly enough), emailing it to myself, then copying into a new page and making the old page private. Or you can trash old page as suggested above.

    Yes, it’s happened a few times to me now too, and it’s a bummer because my books page kind of drives the navigation for the site. I don’t have the quickpress app I’m afraid. Looks like I’m going to have to trash the page and start again, which will mess up all my links from my books on my posts page and widgets. Wouldn’t mind if I could be sure it wouldn’t happen again – I’m not doing anything complicated.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Cannot Edit One Specific Page’ is closed to new replies.