WordPress.org

Support

Support » Plugins and Hacks » WP Offload S3 Lite » Cannot edit media images in WordPress due to this plugin

Cannot edit media images in WordPress due to this plugin

Viewing 7 replies - 1 through 7 (of 7 total)
  • Probably not. I’m not sure how the WordPress image editor works, but i would imagine it is saving the file to the WordPress installation and not the S3 location. The plugin will still tell WP to look for the image at the S3 url, not the installation location.

    If WP saves edits to the image directly back to the file, that won’t work either. S3 doesn’t support overwriting existing images, they are usually prepended with a -01, -02, etc.

    Right-click the broken image and check the url being used as the source. That will give you a hint as to what the issue may be.

    I uploaded an image, attempted to resize it, and WP says everything worked, but when I go to the image, it is the same size as it was before. Your install can’t make changes to the file uploaded to S3.

    Yeah.. I was experiencing the same issue.. it looks like it edits the image but it doesn’t.

    Photon (Jetpack’s CDN) has a similar issue with editing Avatars in Buddypress.. but works fine with images in the Admin area, so there is probably a solution buried in their code somewhere. BUT Photon broke Avatar uploading and editing in Buddypress, which we just solved over here.

    So I guess Photon is the way to go for now.

    I am having the same issue but I discovered that if I DON’T remove the link to the full size graphic it works ok. But If I don’t want a link and select none I can no longer use the Edit or Delete icons on the graphic. Hope this helps to resolve the issue.

    Hi,

    We’re having the same problem on our site. Has anyone solved this problem already? Is there any workaround?

    Thank you.

    Add a link to the graphic using the link icon on the tool bar. Make your changes to the edit image icon. Then remove the link again.

    http://www.sawright.net/?p=1345

    Hi @sawrightnet,

    Thank you for your response. However, what i mean is when i try to crop/scale the image from Admin>media>library>edit, the image seems to be modified but it’s not actually uploaded to amazon s3 after saving, the edited image versions stay on the server.

    I am having the same issue. After edit, the new versions are stored at local instead of uploaded to S3. By the way, S3 will overwrite the same file if vesioning is not enabled.

    Any fix planned?

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Cannot edit media images in WordPress due to this plugin’ is closed to new replies.
Skip to toolbar