Support » Fixing WordPress » Cannot edit in visual mode

  • I am unable to edit my WordPress blog in visual mode. I’ve searched the forums for solutions, but have been unable to find one. If I’ve overlooked something, feel free to simply supply the link. In short, I am able to edit posts in html mode, but not using the visual editor. Here is a screen shot of what it looks like when the “visual” tab is selected:

    Here are some details:

    • I am running 3.8.1, single install.
    • I’m using the Genesis framework, the child theme is “Balance.”
    • When I select the “visual” tab, no text appears, even if the post has content.
    • I have tested this in Chrome and Firefox with the same result.
    • This is a relatively new installation of WordPress, and it occurred in 3.8 as well as in the new 3.8.1 version. I cannot say if it happened from the beginning, because I almost always edit in html mode and didn’t discover this until about two weeks ago.
    • I have tried disabling all plugins (although not deleting them). I don’t have many plugins, and none that seem relatively obscure/unknown. A quick search doesn’t bring up other plugin users with the same issues.
    • I reinstalled WordPress 3.8.1 (replacing all files except wp-config.php and the content folder).
    • My site is hosted on GoDaddy, if that matters.
    • There are some JavaScript errors on the “edit post” page, which I’ve copied below (I know next to nothing about JavaScript).

    Consider using ‘dppx’ units instead of ‘dpi’, as in CSS ‘dpi’ means dots-per-CSS-inch, not dots-per-physical-inch, so does not correspond to the actual ‘dpi’ of a screen. In media query expression: print, not all, (-webkit-min-device-pixel-ratio: 1.25), (min-resolution: 120dpi) post.php?post=1405&action=edit:1

    event.returnValue is deprecated. Please use the standard event.preventDefault() instead.

    Uncaught TypeError: Cannot call method ‘create’ of undefined measureIt.js:120

    Failed to load resource: the server responded with a status of 404 (Not Found)

    Failed to load: wp-tinymce.php:1

    Here’s the site:

    Thanks in advance!

Viewing 7 replies - 1 through 7 (of 7 total)
  • Have you tried:

    – switching to the default theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading all files & folders – except the wp-content folder and wp-config.php & root .htaccess files – from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

    ESMI, me and other people has seen the same issue within the past day or so.

    I looked in the JS debugger, and I can see the DPI warning. However, I don’t get the failed load resource error.

    Failed to load resource: the server responded with a status of 404 (Not Found)

    Yet, I still don’t get a visual editor. (?)

    hi Benjer,
    please check a setting in user–> your profile section
    there is a checkbox with label visual editor and tagline “Disable the visual editor when writing”
    check it is unchecked….

    I’m not sure for Benjer, but I’ve done it:

    Not unchecked. No visual editor. No obvious missing or renamed tinymce.js file either

    Just a FYI — I have resolved my problem with the visual editor. See this thread:

    virendra930: yes, I already checked that “Disable the visual editor when editing” was not selected.

    esmi: I reset the plugins folder as suggested, and deleted and uploaded all WP files except the files you mentioned. I also switched to the bare Genesis theme as well as one of the themes that comes with the WordPress installation…same problem. At a loss.

    Not sure if this info will help or not, but I am running 3.8.1 clean install and Customizr theme, and while I am able to use the visual editor it is not working properly (if I even click on it my HTML gets corrupted/overridden.) Possibly a theme-specific issue, but the only issue Chrome developer tools reports, during page load, is the following warning:

    event.returnValue is deprecated. Please use the standard event.preventDefault() instead. jquery.js?ver=1.10.2:4

    That’s one of the ‘errors’ you mention Benjer (without the version info.)

    Could you provide the version info Benjer? It may help narrow this down.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Cannot edit in visual mode’ is closed to new replies.