Support » Fixing WordPress » Cannot Edit Galleries Once They Have Been Added

  • I am able to add Galleries to Posts just fine using the Upload/Insert Add an Image feature.

    I have a problem once the Gallery has been added to the post – and looks like a Large Blue Box with picture icon – and the Delete and Edit buttons on the top left.

    Clicking the Edit Button on a Gallery that already exists in a post gives me the error below in the overlay window that should be showing the Gallery Edit Screen.

    — notice the double slashes after wp-admin —

    Precondition Failed

    The precondition on the request for the URL /wp/wp-admin//media-upload.php evaluated to false.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    Any ideas?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Also – I CAN edit Single Photos once they have been added. Something is up with Galleries.

    I’m having the exact same issue. I could edit it two days ago, but all of a sudden I’m getting that same error. Did WP update something?

    Glad I’m not alone.

    I actually have multiple sites that utilize WP Galleries – all on the latest version of WP.

    All work just fine – except for this one – which is on a different host.

    I’m wondering if it has something to do with mySQL or a PHP Config specific to this host???

    Trying the .htaccess security fixes I found around Google didn’t help…

    I was just trying some of those now, not working for me either. Will keep looking and keep you posted.

    I’m waiting for the day a website can be made in an app like Photoshop, exported and have it work consistently, stay flexible and update-able via the web but predictable like a normal app.

    Ok – setups that work are:

    mySQL: 5.2.6
    Server API: Apache 2.0 Handler

    Setup that does not work:

    mySQL: 5.2.17
    Server API: CGI/FastCGI

    Not sure what other info would be needed to troubleshoot this?

    I am having the same issue. I tried mod security but it didn’t work. Does anyone have a fix?


    No one with any other ideas?

    I deleted my whole WP install, re-installed everything, and still have same issue. :/

    Maybe it’s a new WP version issue? Will try to downgrade.

    Installed the old version of WP 3.1, still same issue.

    I don’t know what happened, but I had said a prayer to Krishna yesterday to help fix this for my client, and somehow or other, this morning, it works. I can’t explain it any other way.


    hey,how i can find site uri,not url 🙂

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Cannot Edit Galleries Once They Have Been Added’ is closed to new replies.