[resolved] Cannot Edit Certain Posts (6 posts)

  1. livelearncreate
    Posted 7 years ago #

    I am running 2.7 and I have a user (Editor) who posts on a daily basis. The problem we are seeing is that neither he nor I can edit most of his posts. When you click on the Edit link or the post Title in the admin area you get this result on the page:

    Fatal error: Call to undefined function: normalize_whitespace() in /nfs/c03/h03/mnt/55208/domains/proximitymagazine.com/html/wp-admin/edit-form-advanced.php on line 49

    Now, if I use the quick edit option and I either shorten the permalink (I've read elsewhere that 30+ characters in your permalink causes problems) or even if I don't change anything and I click "Update Post"
    then the normal editing ability works.

    Why, why, why am I getting this? I can't go in and do this work around on every single post!

    Please help.

  2. MichaelH
    Posted 7 years ago #

    Doesn't make much sense does it?

    Maybe try uploading a new copy of wp-includes/formatting.php (the file containing the function normalize_whitespace).

    Make sure to use ASCII file transfer mode when uploading.

  3. MichaelH
    Posted 7 years ago #

    Might also check your log files to see if any errors are report or ask your host if they have any input, if the problem persists.

    Also this:

    Turn PHP debugging on and check the log file:
    add this to .htaccess

    # supress php errors
    php_flag display_startup_errors off
    php_flag display_errors off
    php_flag html_errors off
    php_flag log_errors on
    php_value error_log /tmp/wordpress_errors.log

    (or whatever log file location you want)

  4. livelearncreate
    Posted 7 years ago #


    Looking at the formatting.php file that comes with the 2.7 download it is very different from 2.6, which doesn't have normalize_whitespace() anywhere in it.

    So I think the problem comes from the Automatic Update plugin. Did it not replace that file? Might there be a better way to find the log for the update and I'll try to let the developer know that this happened.

    I wonder if there isn't a better way to know when and if certain files are not replaced or overwritten.

    Anyway...thanks so much. Really happy to not have to turn on debugging.

  5. MichaelH
    Posted 7 years ago #

    Deactivate and delete the Automatic Update Plugin as 2.7 has the ability built-in.

  6. livelearncreate
    Posted 7 years ago #

    Ah! Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic