Support » Plugin: Booking Activities » Cannot edit calendar or activities

  • Resolved hancruz

    (@hancruz)


    Hi,
    I have just logged onto to load new activities into the calendar after not using it since March due to COVID19 and it is not working.

    I can’t edit the calendar or activities in Calendar Editor in the backend. Neither the cog icons or the plus icons in Calendar Editor open the popup to edit or add to the calendar.

    Have tried all the steps on your website – deactivating plugins etc and its till not working.

    Please assist.

    Error codes from console below

    load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.4.2:8 JQMIGRATE: Migrate is installed, version 1.4.1
    moment.min.js?ver=2.22.2:1 Deprecation warning: use moment.updateLocale(localeName, config) to change an existing locale. moment.defineLocale(localeName, config) should only be used for creating a new locale See http://momentjs.com/guides/#/warnings/define-locale/ for more info.
    Y @ moment.min.js?ver=2.22.2:1
    T @ moment.min.js?ver=2.22.2:1
    ut @ moment.min.js?ver=2.22.2:1
    ot @ moment.min.js?ver=2.22.2:1
    (anonymous) @ admin.php?page=bookacti_calendars:2865
    fullcalendar.min.js?ver=3.10.2:7 Uncaught TypeError: Cannot read property ‘replace’ of undefined
    at dayOfMonthFormat (fullcalendar.min.js?ver=3.10.2:7)
    at Function.<anonymous> (fullcalendar.min.js?ver=3.10.2:7)
    at Function.each (load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.4.2:2)
    at o (fullcalendar.min.js?ver=3.10.2:7)
    at Object.<anonymous> (fullcalendar.min.js?ver=3.10.2:7)
    at e (fullcalendar.min.js?ver=3.10.2:6)
    at Object.<anonymous> (fullcalendar.min.js?ver=3.10.2:6)
    at e (fullcalendar.min.js?ver=3.10.2:6)
    at Object.<anonymous> (fullcalendar.min.js?ver=3.10.2:12)
    at e (fullcalendar.min.js?ver=3.10.2:6)
    dayOfMonthFormat @ fullcalendar.min.js?ver=3.10.2:7
    (anonymous) @ fullcalendar.min.js?ver=3.10.2:7
    each @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.4.2:2
    o @ fullcalendar.min.js?ver=3.10.2:7
    (anonymous) @ fullcalendar.min.js?ver=3.10.2:7
    e @ fullcalendar.min.js?ver=3.10.2:6
    (anonymous) @ fullcalendar.min.js?ver=3.10.2:6
    e @ fullcalendar.min.js?ver=3.10.2:6
    (anonymous) @ fullcalendar.min.js?ver=3.10.2:12
    e @ fullcalendar.min.js?ver=3.10.2:6
    (anonymous) @ fullcalendar.min.js?ver=3.10.2:6
    (anonymous) @ fullcalendar.min.js?ver=3.10.2:6
    (anonymous) @ fullcalendar.min.js?ver=3.10.2:6
    (anonymous) @ fullcalendar.min.js?ver=3.10.2:6
    locale-all.js?ver=3.10.2:1 Uncaught TypeError: Cannot read property ‘datepickerLocale’ of undefined
    at Object.<anonymous> (locale-all.js?ver=3.10.2:1)
    at a (locale-all.js?ver=3.10.2:1)
    at Object.<anonymous> (locale-all.js?ver=3.10.2:6)
    at a (locale-all.js?ver=3.10.2:1)
    at locale-all.js?ver=3.10.2:1
    at locale-all.js?ver=3.10.2:1
    at locale-all.js?ver=3.10.2:1
    at locale-all.js?ver=3.10.2:1
    (anonymous) @ locale-all.js?ver=3.10.2:1
    a @ locale-all.js?ver=3.10.2:1
    (anonymous) @ locale-all.js?ver=3.10.2:6
    a @ locale-all.js?ver=3.10.2:1
    (anonymous) @ locale-all.js?ver=3.10.2:1
    (anonymous) @ locale-all.js?ver=3.10.2:1
    (anonymous) @ locale-all.js?ver=3.10.2:1
    (anonymous) @ locale-all.js?ver=3.10.2:1
    templates.min.js?ver=1.8.4:1 Uncaught TypeError: f.fullCalendar is not a function
    at bookacti_load_template_calendar (templates.min.js?ver=1.8.4:1)
    at HTMLDocument.<anonymous> (templates.min.js?ver=1.8.4:1)
    at i (load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.4.2:2)
    at Object.fireWith [as resolveWith] (load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.4.2:2)
    at Function.ready (load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.4.2:2)
    at HTMLDocument.J (load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.4.2:2)
    bookacti_load_template_calendar @ templates.min.js?ver=1.8.4:1
    (anonymous) @ templates.min.js?ver=1.8.4:1
    i @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.4.2:2
    fireWith @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.4.2:2
    ready @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.4.2:2
    J @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.4.2:2

Viewing 1 replies (of 1 total)
  • Plugin Author yoancutillas

    (@yoancutillas)

    The problem was solved by email.

    The issue was that the WPLANG option was set to “en”, which is an incorrect value for the outdated momentjs library currently included in WordPress.

    The solution is either to
    – set the WPLANG option to en_US for example (simply save changes in Settings > General)
    – update the momentjs library to the latest version

    The first solution was adopted here because a plugin shouldn’t replace a file provided in WP core since WP and a lot of plugins / themes rely on it.

    However, I have opened a ticket to request to update momentjs in order to permanently fix that issue, causing troubles to other plugins and themes as well: https://core.trac.wordpress.org/ticket/50408#ticket

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.