Support » Fixing WordPress » Cannot edit a draft post since 3.6 upgrade

  • Resolved claimingkin


    Greetings Support Team,

    I was going to complete a draft post that I had saved before the upgrade to 3.6 on Friday, and now I’m not able to make any edits in visual or text mode. Here is a list of things I noticed I’m not able to do since accessing my draft post:

    1. The only visual button I have access to along my toolbar is the “Add Media” button. That’s it! Not sure where all the other buttons such as — bold, underline, italics, etc. — went . . but they are all missing.

    2. I notice that I am not able to toggle open any of the screen options that I use in the dashboard area of my blog. Not quite sure what’s going on with that, but I cannot toggle open any of them.

    3. I use WordPress SEO by Yoast and I’m not able to toggle open the drop down menu to type in my SEO title, Meta description, etc.

    4. I don’t care which mode I’m in – Visual or Text – the content area where I know I typed information and saved it a week ago is not visible either. I know that there is text there because when I click and drag my mouse over the whole content area which highlights it, I can see what I have written. But when its not highlighted, the content area of my draft post is blank.

    5. I can type the tags in the field that I want to assign to my post, but when I click the button to add them, the button doesn’t work.

    Before posting here, I did go do some of the quick trouble-shooting suggestions that were offered with 3.6. Here is what happened with those suggestions:
    1. I did clear browsing data such as emptying cache and deleting cookies and other sites and plug-in data. That didn’t solve my problems.
    2. I deactivated all of my plugins to see if that helped – It didn’t change anything. So I reactivated them one by one and still there was no change.
    3. I switched to the 2012 theme to rule out that there may be conflicts with my customized theme. The same issues that I’m having with my customized theme showed up with this 2012 theme activated.
    4. As far as manually upgrading to version 3.6, that is what I did in the first place. I don’t like the automatic upgrade feature because it does strange things to my customization. So I’ve been doing manual upgrades since I launched my blog online January 2011.

    So . . .

    Would it be better if I re-install version 3.5.2 for now until all the kinks with 3.6 get worked out at this time?

Viewing 11 replies - 1 through 11 (of 11 total)
  • John Parris



    Did you have all the plugins deactivated and use the 2012 theme at the same time while they were deactivated?

    The automatic updates should do nothing do your customizations unless your customizations are touching core files.

    Have you tried reinstalling 3.6 again, overwriting all files and folders except for wp-content?

    Hi mindctrl,

    Thanks for your feedback!

    I did have all the plugins deactivated when I activated the 2012 theme. Then I activated the plugins to see if they were a problem. The 2012 theme did the same thing as my customized theme with this new version installed.

    I probably should have said the WordPress version automatic updates is what I don’t use because it definitely does strange things to my customization.

    I did have to re-install 3.6 late Friday because some of the files in the download from were corrupt. Once I did that, it did fix the problem I was having Friday. So I guess I will have to do this process all over again <<sigh>>

    Okay, I will try another reinstall of this theme again. Thanks!

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    What automatic update tool are you using?

    Within my dashboard, whenever there is a new version of WordPress released, there is a link that will allow me to do an automatic upgrade to the new version once I have backed up my database and deactivated all plugins.

    I just prefer to do a manual upgrade every time to the latest version because I don’t have to deal with the automatic upgrade sending up the config-sample.php file when I have a perfectly configured one there already.

    That’s all.

    I will let you know if the reinstall takes care of my issues that I’m currently having with editing post in the 3.6 version.

    Greetings everyone,

    I deactivate all of my blog’s plugins and backed up my database.

    Then I deleted all of the 3.6 files from my hosting server that I uploaded Friday with the exception of my wp-content and config.php (those were already there).

    Then I downloaded a new 3.6 file from

    I ftp up all of the new 3.6 files with the exception of the wp-content and config.php to my hosting server again.

    I ran the wp-admin/upgrade.php, logged into my blog activated all of my plugins and once again, I am not able to make any edits to blog posts as well as the other things I could not do that I listed in my initial support ticket here.

    I truly appreciate all of the help and suggestions that you’ve provided, but I think I am going to downgrade to 3.5.2 so that I can get some post that I need to publish this week done on time. This will also give the WordPress team time to work out all of the kinks. I will try the upgrade again in a few weeks to see if it will work.

    Again, thank you!

    John Parris



    Can you list all the plugins you have installed on your site?

    How you tried another browser?

    Can you enable debug and show us any errors that show in the debug.log?

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    I ran the wp-admin/upgrade.php, logged into my blog activated all of my plugins and once again, I am not able to make any edits to blog posts as well as the other things I could not do that I listed in my initial support ticket here.

    You’re doing ONE thing wrong here. Do NOT activate your plugins again. Does the site work without them after your upgrade on the clean setup?

    You really do have to test each step of the way :/

    Also make sure you disable any mu-plugins if you have ’em.

    Hi mindctrl,

    Sure I can list all of the plugins I have installed. Here goes . . .
    Broken Link Checker
    Compact Audio Player
    Contact Form Plugin
    Disqus Comment System
    FeedBurner FeedSmith
    Google Analytics Dashboard
    Google Analytics for WordPress
    Google XML Sitemap
    Really Simple CAPTCHA
    Reveal IDs
    WordPress Mobile Edition
    WordPress SEO
    WP Super Cache

    I also have Maintenance Mode installed, but only activate it when I servicing my blog

    With regards to using other browsers . . .
    I have the following browsers installed and tested my blog on all three of them and nothing changed. My blog continued to behave the same:
    Chrome (Version 28.0.1500.95 m)
    IE (Version 10.0.9200.16635
    Firefox (Version 22.0)

    I will have to do some reading up on “enabling debug.” I’m not sure what it is, but I’m willing to give it a try. I will check out the hyperlink you provided and let you know when I have it enabled.


    Hi Mika,

    Okay, I will test my blog to see if I am able to edit posts before I activate the plugins right after a fresh install. I will let you know what happens.

    Thanks so much!

    Thanks to everyone for your suggestions!

    Because I didn’t really have the time to continue with all the troubleshooting 3 weeks ago, I simply downgraded to the previous WP version I was using before the upgrade to 3.6. Today, I decided to attempt the upgrade again and it worked!

    Did I do anything differently from what I was doing 3 weeks ago when I was having problems with this upgrade? Nope. I did what I’ve always done since I installed WP on my hosting server in 2011.

    So this support ticket is officially resolved!

    Iam not able to view my text on my post , anyone can assist me here

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Cannot edit a draft post since 3.6 upgrade’ is closed to new replies.