Support » Plugin: Stop User Enumeration » Cannot disable some Options

  • Resolved James Hunt

    (@rite8rite)


    I am using WP 5.5 but I cannot disble the 2 options below after saving the settings, other options can be disabled without problems.

    Stop REST API User calls
    Stop oEmbed calls revealing user ids

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Alan Fuller

    (@alanfuller)

    Can you elaborate ‘cannot disable’? Do you mean that when you untick and save the tick appears back, or do you mean you untick and save, but the functionality still occurs? You can use screenshots here, but you will need to link to them e.g. bbimg etc

    The version of WP shouldn’t make a difference.

    One thing you could try is deactivate & delete the plugin, this will remove any stored options. Then re-install.

    Thread Starter James Hunt

    (@rite8rite)

    Hello Alan,

    Thank for looking into the issue I am experiencing.

    You are correct, I have unticked the boxes and saved the settings, but then the checkboxes are shown with a tick again and there is no way to disable the 2 options mentioned.

    I also tried to delete the plugins and re-installed them but still no luck.

    BTW, I am using the latest version of the plugin in conjunctin with WP v5.5.5.

    Hope this helps.

    Regards,
    James

    Plugin Author Alan Fuller

    (@alanfuller)

    I’ll take a close look at the code, but if that is happened to just two tick boxes and not the others, I assume you tried unticking the others, that does sound rather strange.

    Version of WP should make zero difference.

    Thread Starter James Hunt

    (@rite8rite)

    Hello Allan,

    Yes, no issues with other options but the only 2 mentioned.

    I managed to fixed this by disabling all my plugins and re-enabled them all. I can now disabled the 2 options that were having issues with. However, I am unable to identify which plugin was conflicting with yours as I cannot replicate the issue anymore.

    But truely thanks for your attention on this and for developing this must have awesome plugin!

    Cheers,
    James

    Thread Starter James Hunt

    (@rite8rite)

    Hello Allan,

    I believe I have now identified the conflicting plugin, it was Cachify!

    As soon as I flush my cache with Cachify (using Harddisk cache), I am no longer able to disable the 2 options. I think the issue reported is more to do with Cachify than yours. Hope this helps.

    Cheers,
    James

    • This reply was modified 8 months, 4 weeks ago by James Hunt.
    Plugin Author Alan Fuller

    (@alanfuller)

    Interesting, however I have also found a bug in my code. So maybe that combined.. I’m not sure. Let me testa and release and see if the issue persists.

    Plugin Author Alan Fuller

    (@alanfuller)

    I have released 1.3.33. I was able to replicate an issue similar to yours, without Cachify and so I think 1.3.33 will resolve your issue.

    Thank you for you contribution to the project by pointing out the issue, much appreciated.

    Thread Starter James Hunt

    (@rite8rite)

    Hello Alan,

    The problem is now resolved using the v1.3.33, those options can now be disabled!

    Thank you for having those looked at and addressed with no time!

    Have a good day!

    Cheers

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Cannot disable some Options’ is closed to new replies.