Support » Plugin: qTranslate X » Cannot disable accessibility mode on widgets page.

  • Resolved C-In-OFF

    (@c-in-off)


    I enabled the accessibility mode on widgets page through screen options but now I want to disable it and get back to the drag-and-drop state.

    A long time I can not understand why it does not work.

    But if you deactivate the qTranslateX plugin, then everything is OK.
    I tried it on several sites with different themes.
    I tried the new clear site (clear Theme 2016), where there is no other plug-ins.

    https://wordpress.org/plugins/qtranslate-x/

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author John Clause

    (@johnclause)

    I have just tested accessibility mode on widgets page under Twenty Sixteen and it all seems to work. Please, describe the precise steps to reproduce the problem.

    You say that I’m lying?

    Qtranslate-X is a very good and I like it.
    And I do not need accessibility mode on widgets page!
    And I do not care what the authors plugin think about this problem.

    This is generally not a problem!

    I think that the author will be interesting.

    As proof:
    Go to http://draft.besaba.com/wp-login.php
    Login: qtranslatex
    Password: qtranslatex

    Simply activate accessibility mode on widgets page, and then try to activate it.

    Good Luck!

    P.S.
    Password is valid for 10 days

    Plugin Author John Clause

    (@johnclause)

    >You say that I’m lying?
    Oh common, no, that is not what I meant 😉 I said that I cannot reproduce so far, it means that more information is needed. There might be numerous reasons why you observe a problem and I do not. Figuring it out is what troubleshooting process is about. I’ll take a look at your link.

    Plugin Author John Clause

    (@johnclause)

    I am puzzled. I still cannot reproduce it on my computer and on a few other sites either. There are strange JS errors though:

    Uncaught ReferenceError: wpWidgets is not defined
    Uncaught TypeError: Cannot read property 'hasClass' of undefined

    first of which I also get on my servers, but it does not cause the problem. Second one is “property” of your server only. I guess, the problem has something to do with those errors. The first one comes from qtx code like this:

    if(wpWidgets){ ... }

    Global object wpWidgets is defined in one mode and is not defined in other mode. I would think that ‘if’ is allowable code when wpWidgets is not defined, but somehow it produces error in this case.

    On your server, I also occasionally get white page with two words “Access Denied”. Something is unusual is on your server.

    I’ll try to research and get rid of the first reproducible error, and then maybe it will work on your server too.

    Plugin Author John Clause

    (@johnclause)

    Ok, I checked in the two files changed:

    https://github.com/qTranslate-Team/qtranslate-x/blob/stable/admin/js/widgets-exec.min.js
    https://github.com/qTranslate-Team/qtranslate-x/blob/stable/admin/js/widgets-exec.js

    Could you replace those files on your server and see if the problem is still there? Do not take the whole plugin from GitHub (it needs more testing), just those two files.

    Thanks a lot!

    Yes John.

    Now OK. I replaced these two files. Now you can switch the accessibility mode. http://draft.besaba.com/wp-admin/widgets.php

    Good job.
    I want to say that this server is simply to demonstrate the problem for U. (Very slow free hosting.)
    Initially, the problem was discovered on another servers on another hosting on different sites. Different OS. This is not a problem server settings 100%.

    I accidentally detected this problem, solve the other problems. Now the plugin will be even better. ))

    Plugin Author John Clause

    (@johnclause)

    Thanks a lot for your report and letting us test on your server.
    Good luck to you in your further development!

    ya im heaving the same prob with the latest version i dont know if this if was added or not.

    fast fix in the mean time you can run this in the URL of WP to tern off the widgets accessibility mode.

    domain.com/wp-admin/widgets.php?widgets-access=off

    Plugin Author John Clause

    (@johnclause)

    I am sorry for your trouble. We currently do not have resources to answer support questions for free and rely on the community to provide a possible solution, which seems to work well in many cases. Many thanks to our active community members who take a good time to answer people’s problems!

    Most of the problems should be resolvable with https://qtranslatexteam.wordpress.com/integration/ and https://qtranslatexteam.wordpress.com/troubleshooting/, as well as many questions are addressed in FAQ, https://qtranslatexteam.wordpress.com/faq/.

    We need to figure out a way to monetize the support and further development. We would highly appreciate if you take about 5 minutes of your time to respond to the survey linked here: https://wordpress.org/support/topic/what-is-the-future-of-qtranslate-x/

    Any ideas and additional input are also welcome, use the same thread linked above for everyone to see your thoughts.

    Thanks a lot!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Cannot disable accessibility mode on widgets page.’ is closed to new replies.