Support » Fixing WordPress » Cannot delete WordPress directory because of wp-content/cache

  • Hi guys, I wanted to try and install a different blogging platform real quick and decided that I would try to make it as clean as possible. I backed up everything, including my database files and went on to deleting my wordpress directory on my server. What’s weird is that I couldn’t. I’m using Transmit on the Mac and whenever I try and delete the
    wordpress’ directory, I’m getting this error:

    Server said:
    wp-cache-11f085c105e58ffc44c04fd8ab1ab305.html: Permission denied

    Error -144: remote delete failed

    I’ve tried and changing my permissions for the directory to 600, 660, 666, and as a last resort 777. Everything else has been deleted from the ‘wordpress’ directory except the files inside ‘wordpress/wp-content/cache/*Various Cache Files Here*’.

    By the way, since everything has been deleted, including the database, I can’t really install WordPress again to disable any plugins, etc. Any suggestions on how to solve this, or should I just contact my hosting service (Laughing Squid) so that they can just restore my server to it’s clean, untouched state? Thanks in advance!

Viewing 6 replies - 1 through 6 (of 6 total)
  • whooami



    the files arent owned by you. Use whatever control panel access they give you, assuming it has some sort of file manager, you should be able to dele the files through that.

    Sometimes you can wait couple of hours (or days) so that file/folder is not used by anything, and then it can be deleted.
    Also, if you have cPanel or similar control panel software, try to delete it through it’s file manager, not through FTP.

    Thanks for the very quick responses! I’ve tried to delete the files in the CPanel that they provide me. I’m still getting the errors that I’ve listed above. It’s not the exact same warning, but it’s the same idea: “The files cannot be deleted, they are in a higher permission, etc.” I’ll try again in a couple of minutes Avram. I wonder if the cache will expire in half an hour and will be able to be deleted…Thank for the advice!

    Alright, something else that’s weird is going on now. Whenever I try to access the ‘wordpress/wp-content’ directory, I’m now getting a message saying that it doesn’t exist. I went back into the control panel, and I’m still receiving the error stating that the cache files cannot be deleted because of permissions.

    Create a file named unlink.php in your wp-content folder with this in it:

    <?php unlink("cache/wp_cache_mutex.lock"); ?>

    Then access it from the browser:

    It will unlink the cache/wp_cache_mutex.lock, so you can delete the folder. You can delete unlink.php afterwards.



    Volunteer Moderator

    Thank you wooptoo. This came in handy when I uninstalled the plugin for friend. Cheers.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Cannot delete WordPress directory because of wp-content/cache’ is closed to new replies.