Support » Fixing WordPress » Cannot delete posts, pages, drafts and comments

  • Hello everyone, I am using 2.1.2 and just recently it became impossible to delete posts, pages, drafts and comments. When I click on “delete”, it asks me to confirm and I do. It appears that it was deleted but when I refresh, blammo, the damn thing is back. It seems that the only way to truly delete the thing is to go into my database. The problem is that it is pretty cumbersome to do this.

    Here is what I have tried so far:

      1. reuploaded wp-admin… didn’t work
      2. tried “edit” then “delete”… still there!
      3. turned off visual editor… doesn’t work
      4. disabled all plugins… no avail
      5. tried cpradio’s suggestion of running a query on my database –> SELECT * FROM wp_options WHERE option_name LIKE ‘%user_roles%’

    As I write this I am reuploading wp-admin once again. If that doesn’t work, I’ll be forced to jump out the window. Any help would be greatly appreciated.

Viewing 12 replies - 1 through 12 (of 12 total)
  • – What specific browser, specific browser version and specific os are you using?

    – Any security programs in place?

    – Have you done anything or made any changes recently to your wp install?

    Hey drmiketemp, thanks for the help. I am using Firefox with XP mainly but I have the same problem with IE 7. I use Kasperky Internet Protection but even when I temporarily disable it, I still have a problem. As for changes to my install, I cannot think of any. I even disabled all plugins and still get a problem. The only thing that I know has changed is my sanity!

    Hello, I’m not sure if this would help, but did you try a database repair? (in phpmyadmin, under the list of your tables, a drop-down menu “with selected” and choose repair table).

    Hey Nadglobtrotter, thanks for the help. I just tried repairing the database and it did not work.

    May be this is related or maybe not, but when I publish a post, it does get published. However, WP always takes me to a totally blank page. In addition, whenever I try to search my posts, it comes back with nothing. However, if I search by post number, it does return results but they are incorrect. For example, I searched for 7218 and it came back with 6584 which does not have 7218 anywhere in the post. Weird.



    I had this happen once, and I fixed it by reinstalling WordPress (as per the upgrade instructions).

    Man, I don’t know how I fixed this problem before but I am now having it again. However, this is on a new blog.

    I tried “Edit” –> “Delete” and this just takes me to a blank page and when I refresh, the post is back.

    The only way that I can delete a post is to go into my database and delete it there which is a pain in the ass. Does anyone have any clue how to fix this?



    Please, don’t double post – I am fast with the delete button!

    So how should I post this? It’s kind of a new problem since it’s a whole new blog but it’s the same… know what I mean? That’s why I posted another topic with a link to this topic so I wouldn’t have to explain everything a second time.

    Also, I wasn’t sure if this topic would show up near the top of the listings since it was started 6 months ago. Any suggestions on how to get so help with the posts?



    Also, I wasn’t sure if this topic would show up near the top

    If you add a new post – it always go to the top…

    I have seen similar posts and it always seems to be some weird settings on the user’s computer or on his server.
    Did you try to let a friend to log in from a different location to try to do what doesn’t work for you? (just an idea)

    Also, in some cases it is a security setting on the server. For that you may try to upload a .htaccess file to your wp-admin folder (this is NOT the same as the .htaccess fiel for your WP’s nice permalinks!)
    that has these lines:

    <IfModule mod_security.c>
    SecFilterInheritance Off

    Temporarily, you can delete them using IE browser. Then clear out & re-install Firefox.

    I have the same problem on 2.5.1.
    I tried “repair tables ” everything goes green but i can’t delete drafts and categories.
    I tried Internet Explorer browser.
    I tried htacces stuf = same answer

    “Error in deleting…”

    Need help, please.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Cannot delete posts, pages, drafts and comments’ is closed to new replies.