Support » Fixing WordPress » Cannot delete posts as administrator

  • I recently upgraded from 2.0.3 (everything was working fine to 2.0.7 and discovered I could not delete my posts or pages. I am the only user and administrator. I searched these forums, and have read EVERY posting on this, although nothing works. I’ve cleared every cookie, tried every browser, dumped the database, restored the database, dumped and restored/ made new database users, changed file permissions, EVERYTHING! Nothing will allow me to delete posts in mass view. I can edit the post, then Delete it through there, but this is just simply annoying. I want to click and delete. Can anyone help me? I have a feeling it is one little permission on a certain PHP file, but I have no clue what that would be. Please help…i’ve been trying to launch my new site for ages, and was almost there until this little hitch pissed me off. Thanks to anyone who responds…

Viewing 2 replies - 1 through 2 (of 2 total)
  • Okay. So, when you upgraded, exactly what steps did you take? I ask because it isn’t working as it should.

    Did you delete the WordPress files from the server (except the few that don’t need to be deleted) *before* you uploaded the new files?

    And did you then run upgrade.php?

    Believe me, I’ve tried everything. For this specific 2.1 install, I (1)backed everything up, (2) deleted everything except “wp-config.php” (3) deleted everything WordPress related in my install directory, (4) uploaded all new files after making sure everything was there (themes, plugins, etc.) and (5) ran “upgrade.php.” I logged in successfully and can manipulate most everything as normal. The only thing that doesn’t seem to be working is the deletion of posts and pages from the mass edit modes. I thought it might be a plugin that doesn’t work with 2.1, but I’ve deactivated everything, and it still won’t let me delete. Like I said, I can click on the specific post, then deleted from within the editing phase, just not from the listing part.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Cannot delete posts as administrator’ is closed to new replies.