Support » Plugin: Wordfence Security - Firewall & Malware Scan » cannot deactivate wordfence 503 error

  • Resolved arnie78

    (@arnie78)


    hi I cant deactivate your plugin once i click it sends a 503 error.

    WordPress is updated to the latest verson and so is wordfence.

    I have restored the website using managewp a few times and deleted your plugin and the php files from cpanel however no luck.

    When i try to deactivate your plugin is suddenly shows a 503 error screen.

    The hompage loads however its the whitescreen of death…. no content

    I tried clicking the diagnostics however nothing works just sits white screen.

    I love your plugin i have it on numerous websites however this is the only one causing the issue.

    Look forward to you reply

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Thread Starter arnie78

    (@arnie78)

    The same thing has happened on a subdomain, i can login to to the wpadmin from cpanel softaculous installer, however will not let me access if from managewp or wp login page for some reason.

    Thread Starter arnie78

    (@arnie78)

    I have deactivated all other plugins excpet yours and still tried to deactivate with no luck same issue.

    Thread Starter arnie78

    (@arnie78)

    Server is a litespeed server sorry about all the replies

    Hi,

    Try following:

    1. Move the Wordfence directory to another one (wp-content/plugins/wordfence).
    2. You should be able to login into WordPress at this moment.
    3. Now you need to install Wordfence Assistant.
    4. Then run through all options and everything should be completely removed for you.

    The complete guide how to manually delete WF is located here:
    https://www.wordfence.com/help/advanced/remove-or-reset/#remove-or-reset

    Thread Starter arnie78

    (@arnie78)

    thanks for your help however it was your plugin causing issues with my server configuration
    if anyone is having issues on litespeed server do this

    We have found a solution on this issue for the time being, You will need to login to cPanel for your hosting service and select “PHP Selector”

    From here untick:
    mysqli
    pdo_mysql

    And Tick:
    nd_mysqli
    nd_pdo_mysql

    Then press “Save”

    Access to the backend should be restored.

    meme probleme chez Os2switch et server lite … (alors qu’il fonctionnait normalement, plus moyen d’acceder à l’admin, boucle sur wp-login.php sans erreur .

    Merci de la solution cela fonctionne

    Same here. Thanks arnie, that got me back up and running… but is that a permanent solution?

    Same problem here. Tried Removing the Wordfence plugin and all database tables and ini file and could install the plugin but would still 503 when trying to Activate it.

    Arnie’s solution worked a treat. Thanks mate!

    Thread Starter arnie78

    (@arnie78)

    well i dont think its a permanent solution, once more people lodge support tickets with wordfence i think they will update the plugin to fix the issue. I think many people are effected with this issue with those hosting configurations.

    Well great to see I have helped out other users

    cheers arnie

    My host’s solution was “delete the Wordfence folder”. That was a quick fix to get access but I guess begs the question… does my host hate the plugin because it consumes more resources or are they correct in saying that it’s superfluous?

    Hi @arnie78

    Thanks for updating this thread with all your findings, normally, Wordfence should work fine with either pdo_mysql or nd_pdo_mysql, I have it installed on one Litespeed servers with pdo_mysql and it’s just working fine, I can deactivate it normally.

    I believe it’s another server configuration issue that is causing this problem, I recommend checking the server error after trying to deactivate the plugin, more details about this “503 server error” must be there.

    Thanks.

    When wordfence updated to 7.1.2 it crashed one of my sites, in that it only showed 503 errors to everyone logged in or not. But it did not crash the other of my sites, so with some wise counsel I copies the WF folder on one which was still 7.1.1 and erased the 7.1.2 on the problem site and replaced it with the 7.1.1. Then I turned off automatic updates for the problem site. That solved my problem, however, I want to know when WordFence will fix this problem so I can turn updates back on. I dare not run the site without WF on.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘cannot deactivate wordfence 503 error’ is closed to new replies.