Support » Plugin: Titan Anti-spam & Security » Cannot deactivate Plugin

  • WPpress

    (@pikachuchu)


    After updating to Version 7.0.1, the deactivate link does not work.
    Please fix this, I want to deactivate your plugin.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Artem

    (@webtemyk)

    Hello, @pikachuchu.

    Do you see any error? If not, can you take a screenshot of what happens after deactivation?

    feastdesignco

    (@feastdesignco)

    +1 for cannot deactivate.

    Nothing happens – no javascript errors. No page reload. Nothing.

    I’m not even sure how this plugin got onto one of our sites – nothing called “Titan Anti-Spam” was ever installed. This is extremely troubling.

    For anyone else dealing with this – follow option #1 in this tutorial to disable it by renaming the plugin folder: https://www.ostraining.com/blog/wordpress/disable-a-wordpress-plugin/

    Plugin Author Artem

    (@webtemyk)

    This is an Anti-spam plugin. We renamed the plugin because we added security features to it.

    When you click the Deactivate link, a window appears asking you to specify the reason for deactivation. You can click Skip and deactivate.
    If this window doesn’t appear, it means there are JS errors in the browser console

    Charles

    (@charlesrodmell)

    Same problem here. Cannot deactivate. No window appears and no JS errors in browser console. There are some issues on the site that appeared after this update, like for example googlebot mobile version is now classing pages as unreachable 😮
    I wanted to check if it’s this plugin, but obviously can’t using normal methods.

    For now, I’ll rename the plugin folder to deactivate it, but I’m highly worried this addition of security features has interfered with my other security plugin.

    Yes, I should have checked this on my test server first….

    • This reply was modified 1 year ago by Charles.
    • This reply was modified 1 year ago by Charles.
    Plugin Author Artem

    (@webtemyk)

    And after clicking on the “Deactivate” link, are there any errors in the console?

    Charles

    (@charlesrodmell)

    No, sadly nothing.

    I checked other plugins and those deactivate buttons still worked.

    feastdesignco

    (@feastdesignco)

    Do you have an ad blocker? Depending on their deactivation hook, the deactivation survey popup/JS may be getting caught by ad blockers.

    Try deactivating the ad blocker and refreshing the page.

    Developers should remove the exit survey entirely.

    Charles

    (@charlesrodmell)

    No adblocker and no pop-up blocked in Chrome. Sending a vid to the devs now.

    Beth Graham

    (@beth-graham)

    Update: I was able to deactivate and delete it using the apply bulk action function.

    Same thing is happening to me. I want to delete this plug-in. Did anyone find a fix?

    etellewyn

    (@etellewyn)

    I also was unable to deactivate this plugin, but as others have mentioned, using the bulk editor works. But I agree it was very troubling to suddenly see this plugin on my site when I never installed it in the first place! Very ironic for a security plugin because I thought I had been hacked. What plugin did you rename that I might have had installed previously?

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Cannot deactivate Plugin’ is closed to new replies.