Support » Fixing WordPress » Cannot create posts with images – 404 error post.php

  • Hi,

    I have a problem that has become very frustrating and I’m hoping one of you kind souls can help me. These problems are occurring on a first-time install on WP 2.9.2 on a new server. I have used WordPress on other sites successfully.

    When creating a new post, I am unable to insert an image. To be specific, when I insert an img src tag or attempt to “insert into post” using the media library, I get a 404 error (the address bar displays “post.php”) after clicking either “Publish” or “View Post”.

    When I create a post with only text it is displayed as normal without any issues.

    I’ve searched the codex and other sites and have messed with .htaccess, chmod, deactivating plug-ins (the only one is Akismet), etc. I have also deleted the database and WP and completely reinstalled.

    I’m starting to think this is a host issue, but I have no idea what that issue would be. Any and all suggestions are greatly appreciated.

    Thanks

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hi, i got exactly the same problem after upgrade my 2.9 to 2.9.2.

    While upgrade, i did some improvements to .htaccess and installed caching plugin to reduce my monthly bandwidth, so i was thinkig this was a problem.

    I saw this one week later when tried to update one of my posts. I get 404 everytime, like weareweapons says, after clicking publish or view. I can not even change permalink to this post.

    So i tried to make new post and see if it works – yeah, it works fine but until we add image to that post. Empty img src tag causes no problem, but with http:// or full link inside – i get 404. However i can insert images from library, i can upload, etc.

    I downgraded back to 2.9, restored previous copy of database (used with 2.9), restored previous .htaccess, disabled all plugins – still 404.

    I see that i got problems with myphpadmin too, i get wordpress 404 error (with normal url site.com/myphpadmin/index.php…) when try to manually edit records in database, this was working fine before upgrade to 2.9.2

    So if someone resolved this, please help, thanks!

    Oh, it seems like this is mod_security problem. It do not allows to post <img src="http://" /> – when i put stupid bold tag into http
    <img src="http<b></b>://..." />
    it saves post but it is useless now…

    apache log after attempt to post:

    [Mon May 24 00:37:20 2010] [error] [client 89.228.***.***] ModSecurity: Rule execution error – PCRE limits exceeded (-8): (null). [hostname “***.***”] [uri “/wp-admin/post.php”] [unique_id “***”]

    And i see there is a lot problems with mod security and wordpress… http://wordpress.org/tags/mod_security

    Moderator James Huff

    (@macmanx)

    Contact your hosting provider and ask them to lift that limitation, it’s a little bit overkill.

    Yes, this was a mod security problem, administrator has set a high security level after attacks on the server 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Cannot create posts with images – 404 error post.php’ is closed to new replies.