Support » Plugin: OMGF | Host Google Fonts Locally » Cannot create file

  • Resolved ucsendre

    (@ucsendre)


    Hi! After setting up required fonts, variants, subsets and downloading 29 font files, I clicked “generate stylesheet” and it said everything is ready, settings added to my theme css.
    But on after clearing all caches and checking my site in incognito mode browser window, there are a dozen of 404 errors – one for every font file the page tried to load from my server (I did setup CDN, but it did not look there).
    I went back to OMGF admin and checked all settings, I clicked on “generate stylesheet” button again and now it writes in the message line: “Cannot create file /var/www/vhosts/domain.tld/httpdocs/wp-content/cache/omgf-webfonts/fonts.css”
    What did I do wrong?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    Some caching plugins empty the entire wp-content/cache folder, instead of just their own files.

    Move OMGF’s cache folder outside the wp-content/cache directory, using the option under ‘Advanced Settings’. After that, download the fonts and generate them again.

    That should do it.

    Thread Starter ucsendre

    (@ucsendre)

    Yes it is ok now. Thank you Daan!

    😀

    Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    Awesome! Enjoy OMGF!

    Would you like to write a review?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Cannot create file’ is closed to new replies.