Support » Fixing WordPress » Cannot create directory errors

  • Hi friends!

    I recently installed another WordPress blog to my site and I noticed I’ve been having issues with permissions lately.

    I noticed the first error when it couldn’t automatically write the config.php file during installation. Afterwards, it kept asking for my FTP credentials when installing a theme/plugin. While I can do it manually via my file manager on the server end, I can’t through WordPress.

    Now, all my links on the site are broken and lead to 404 error pages. What’s weird is the other WordPress site I ran was on the previous version and worked fine until I switched everything to this new version.

    I made sure that the folders are correctly permissions (775 for folder and 644 for files). I’ve Google’d my problems relentlessly and many suggest changing file permission through the terminal on server side but I checked and those permissions are still okay.

    Not sure where to go from here. Any help would be GREAT!

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Hello, infestlithium, & welcome.

    There’s much you don’t tell us–specifically, whether you’re hosting on a Linux or Windows system, as well as whether your hosting is shared, VPS, or dedicated. You also don’t tell us your webserver, ie, Apache, Nginx, IIS, etc. Those are all important considerations. Also, is this a single or a multisite installation?

    At least on a Linux box, file permissions are not the only causes of this sort of error. Indeed, usually the problem is not the permissions on the files per se, but the ownership. Specifically, the WordPress files need to be run under the webserver user & group, either directly or by having the user & group that owns the files be a member of the webserver group.

    You continually refer to versions, etc, & I’m not clear on what you mean by that term. If you could assist by explaining a bit of the history behind this, perhaps we might better be able to help you.

    I apologize for having more questions than answers for you at this point, but sometimes those questions just need answering in order to solve the problem.

    These symptoms all point to user rights / permissions. Check that. Make sure the owner of your wordpress directory is the webserver user account ( e.g. www-data on debian systems )

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Cannot create directory errors’ is closed to new replies.