Support » Installing WordPress » cannot connect to server

  • showerhater

    (@showerhater)



    hi and thanks for any help.
    i tried to create my own server, on an old laptop, and host a wordpress blog on it as a way to learn linux and networking better. i have installed ubuntu 18.04, apache2, mSQL, php 7 per a tutorial on techmint.com and then tried to install WordPress. i got as far as logged in on the WP dashboard and changed some text, and the hit publish.
    Then, i tried to go to the site from my android phone not connected to the LAN, i got a cannot find server message.
    Then i googled a bit and saw that i might need to change my nameservers and possibly need to create a dns record. i changed the nameservers to wordpress’. didnt work, so i changed them back. i made a clumsy attempt to create a record on google doamins. 50/50 shot at it being right though.
    googled again and found out i may need to change the urls inside wordpress. I logged in to admin through my LAN and changed the site and email urls to mydomainname.com. saved and boom…now i cannot get into my admin page at all now. Now, no matter what i try i get a “cannot find server message”
    I did a complete uninstall and reinstall. same problems.

    So, among other things, I need help figuring out what went wrong and how to get it to work. I dont mind uninstalling and reinstalling, but because i dont know what went wrong i will just create the same situation. ive proved that yesterday, and the day before lol.
    I would also like to know which nameserver to use (wordpress or googles).
    Did i need to make a dns record on google domains to point my domain to my IP or should i delete the one i have made?

    Thanks in advance
    Doug

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • showerhater

    (@showerhater)

    this is my wp-config.php file. im guessing it is correct, but i see a lot of the same kind of problems as mine on here and the first answer usually says it this file. I copy and pasted this then xxx my personal info. can anyone tell me if it is correct???

    // ** MySQL settings – You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define(‘DB_NAME’, ‘wp_xxx’);

    /** MySQL database username */
    define(‘DB_USER’, ‘xxx’);

    /** MySQL database password */
    define(‘DB_PASSWORD’, ‘xxxx’);

    /** MySQL hostname */
    define(‘DB_HOST’, ‘localhost’);

    /** Database Charset to use in creating database tables. */
    define(‘DB_CHARSET’, ‘utf8’);

    /** The Database Collate type. Don’t change this if in doubt. */
    define(‘DB_COLLATE’, ”);

    @showerhater
    1.You have to host your website on a server before you can access it from your phone.
    2.If you want to access your website without hosting you have to connect your Android phone to the same network.You don’t need to change the servername.
    3.Change your servername back to default and try turning off the firewall and change hostname to the IP of your machine.
    Ex define(‘DB_HOST’,’localhost’);
    to:
    define(‘DB_HOST’,’192.168.0.4′);

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.