Support » Plugin: Jetpack by » Cannot Connect Jetpack to

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Contributor Jeremy Herve


    I had a look at your site, and while I could access xmlrpc.php in my browser, it doesn’t seem to be accessible via cURL:

    curl -i -H 'Content-Type: text/xml' --data '<?xml version="1.0&"?><methodCall><methodName>demo.sayHello</methodName><params></params></methodCall>' ''

    The cURL test returned the following invalid result:

    HTTP/1.1 408 Request Timeout

    Could you contact your hosting provider, and let them know about the issue?

    Thanks Jeremy, I will let them know. I’ll post a follow up once i hear from them.

    Jeremy: It seems to be working now after an email to my host Network Solutions. I sent them the info you gave me. Thanks a lot 🙂


    Im having the same problem, but the site has been live for 2 weeks. So not DNS related. When i check the xmlrpc link in the browser, it returns “XML-RPC server accepts POST requests only.”

    and the curl seems to be working fine too. My clients host( has no idea whats going on and it worked in production just fine.

    I am having the same issue The Jetpack server was unable to communicate with your site [HTTP 403]. Ask your web host if they allow connections from I do have xmlrpc.php installed. My blog is The hosting co. is media temple so it is VPS. When I contacted them on the issue they said they are blocking nothing. I turned off all plugins and even put the 2013 theme up temporarily and got the same response. When I type the url in with the xmlprc.php in I get a completely blank page with no writing at all. I went to one of my other WordPress installs and even tried to copy over a new xmlrpc.php file thinnking it might have been corrupted and still has the same issue.

    Plugin Contributor Jeremy Herve


    @western2012 Your problem is similar to the original poster’s: Your XML-RPC file cannot be accessed:


    You don’t have permission to access /wordpress/xmlrpc.php on this server.

    A security plugin or your host may be blocking access to this file. As long as this is the case, you won’t be able to use Jetpack, or any other app or plugin using the XML-RPC file.
    Could you try to deactivate all security plugins, and if that doesn’t help to contact your hosting provider and ask them if they block access top the URL above?

    Thank you!

    Thx, I did turn off all plug ins and that did not help.
    I also contacted media temple, the host, and they have nothing turned off.
    I did, however, think I found the problem. We are using cloud flare on the main site and this is a sub domain of the main site. So what I am going to do this week is give the blog it very own DNS away from cloud flare and see if that does the trick.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Cannot Connect Jetpack to’ is closed to new replies.