WordPress.org

Forums

Jetpack by WordPress.com
[resolved] Cannot Connect Jetpack to WordPress (15 posts)

  1. daninovac
    Member
    Posted 1 year ago #

    My Jetpack worked fine, but I deactivate all of my plugins and when I activate them and I wanted to connect Jetpack to WordPress it gave me an error which says that:
    Your Jetpack has a glitch. Something went wrong that’s never supposed to happen. Guess you’re just lucky: siteurl_invalid
    Try connecting again. Error Details: The required "siteurl" parameter is invalid.

    My site is: http://daninovac.com
    Thanks

    http://wordpress.org/plugins/jetpack/

  2. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Can you please use Jetpack's Debugger module to send us some more information about your site?

    1) Go to the Jetpack page in your dashboard.
    2) Click on the Debug link appearing at the bottom of the page.
    3) Click the link that says "click here to contact Jetpack support."
    4) Fill in the description box and your name and email address.
    5) Click the "Contact Support" button.

    Thanks!

  3. daninovac
    Member
    Posted 1 year ago #

    I've done this already 3 days ago. Karen replied me twice but her solutions wasn't good enough. I can't go trough that site_urlinvalid error. Isn't from the plugins, i've turned them all of, reinstalled JetPack and all that stuff, but doesen't make a difference. I really think it's something from the host server, but I'd like to know what information exactly to send at the host.
    Thanks!

    If it's needed to do that debugging again, I'll do it.

  4. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Could you reply to Karen once again, and let her know that you still experience issues, so she can investigate more about your problem?

    Thanks!

  5. daninovac
    Member
    Posted 1 year ago #

    Yes, I've replied her. Thanks for your help!

  6. daninovac
    Member
    Posted 1 year ago #

    Hi, sorry for the double posts.
    I've replied to Karen, and to Ryan, but after 1 month i still get the same error message and I cannot fix this. And I really need to connect Jetpack on my blog.

    That's what I've tried.
    I've deactivated all plugins, then reactivate Jetpack, or install a fresh copy, or install it from FTP, or disable W3 Cache, or contact the host guys and tell if PHP_FCGI_CHILDREN is set to one and if it is, to change it at two or more, and they replied me that they didn't change anything and everything it's ok. I've tried all these combinations and my error still persist.
    Also I sent a copy to raw server acces logs and made a php file that helped you guys to sift through my PHP settings. I've been asked if the compression is enabled on the server and if it is, I will need to deactivate it, but the hosting provider told me that compression on server is disabled. I don't know what to do!
    I really need an answer and a debugging because I need to run Jetpack on my site.

    Please, help me. I will answer properly and as fast as possible and I will tell you everything you need to make this great plugin work again. Thanks!

  7. George Stephanis
    Automattic Lead Code Monkey
    Plugin Author

    Posted 1 year ago #

    Howdy, Dani.

    I've been seeing your connection attempts, but they've been failing because the IP Address that 'daninovac.com' maps doesn't seem to validate. It to maps to 128.0.46.45 -- so when our code runs filter_var( '128.0.46.45', FILTER_VALIDATE_IP, FILTER_FLAG_NO_RES_RANGE ) -- it returns bool(false) -- it turns up as part of a reserved range of IPs, so it gets rejected by PHP itself.

  8. George Stephanis
    Automattic Lead Code Monkey
    Plugin Author

    Posted 1 year ago #

    It's in the block allocated to RIPE -- I just tweeted them to ask and CC'ed you in.

  9. daninovac
    Member
    Posted 1 year ago #

    Ok, I understand. So what I have to do is to wait?
    Finally, this problem has an answer. Thank you so much, George!
    Thanks, Thanks, Thanks!

  10. George Stephanis
    Automattic Lead Code Monkey
    Plugin Author

    Posted 1 year ago #

    Well, for the moment yes. Once I get an answer from them, I may have to rewrite our IP validator, but I want to make sure it's being built correctly.

  11. daninovac
    Member
    Posted 1 year ago #

    Thank you so much, mister!
    I owe you one.

  12. George Stephanis
    Automattic Lead Code Monkey
    Plugin Author

    Posted 1 year ago #

    Turns out it was an actual glitch within PHP itself, which has been fixed for future releases upstream:

    Bug Report: https://bugs.php.net/bug.php?id=66229

    Fix: https://github.com/php/php-src/commit/8f11f7f179c891a5966eec8f748d486f73ef8fa1

    I'll add in an ifcheck to our servers tomorrow specifically for those IP ranges so they're no longer blocked under current versions of PHP, and update you when you're clear to connect.

  13. daninovac
    Member
    Posted 1 year ago #

    Thank you so much! I'll wait for your sign.
    Thanks, thanks!

  14. George Stephanis
    Automattic Lead Code Monkey
    Plugin Author

    Posted 1 year ago #

    Can you try to connect now? I've added a workaround in to our servers with something like --

    https://gist.github.com/georgestephanis/7793119

    -- and it should work now.

    Be aware, though, that you may find other services that randomly get caught by this as well. Just forward them the PHP bug report and solution above.

  15. daninovac
    Member
    Posted 1 year ago #

    I can't believe I'm using Jetpack again after all that time wihtout it.
    Thank you very much, mister!
    As I said, I owe you one! Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Jetpack by WordPress.com
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic