Support » Plugin: Redis Object Cache » Cannot connect after 1.5 update

  • Resolved godfather21

    (@godfather21)


    Hello,

    after i updated to 1.5 i receive the following
    Status: Not Connected
    Client: PhpRedis (v3.0.0)
    Drop-in: Valid
    Connection Exception: Redis server went away (RedisException)
    Redis Extension: 3.0.0
    Predis Client: 1.1.1
    PHP Version: 7.3.11

    as also on my server logs

    PHP message: PHP Warning: Redis::connect() expects at most 5 parameters, 6 given in /httpdocs/wp-content/object-cache.php on line 465PHP message: RedisException: Redis server went away

    can you please explain to me what can i do in order to make it work? If i install the previous version it is working

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Till Krüss

    (@tillkruess)

    Your PhpRedis is way out of date.

    Thanks for your response,

    i am using redis with plesk onyx, if i update redis then will phpredis be updated too?

    Plugin Author Till Krüss

    (@tillkruess)

    No you need to update the PHP extension.

    Thank you for your answer, problem solved

    Hi,
    I am having exactly the same problem. Save version of phpredis3 and also using Plesk.
    I will try to update phpredis but I feel you are going to have several of these bug reports 🙂

    @godfather21 How do you update phpredis?

    I rolled back to Redis Object Cache 1.4.3 and all works fine.

    I just noticed this issue with failing to connect to my Docker based Redis instances on my AWS Lightsail, Plesk, Ubuntu 16.04 farm. The PhpRedis it was configured with was 3.0 which this plugin no longer supports, likely for good reasons. After a bit of research and trial and error was able to get it working by updating to PhpRedis (v5.0.2) via these steps in SSH CLI. If you’re on a different PHP version or different Linux you’ll need to tweak these. You’ll need to run for each PHP version in use. This installs the compiler tools to compile the latest phpredis, then uses pecl package manager to install it. There was a line saying ‘core dump’ during step 2 but it doesn’t seem to have any impact.

    1. sudo apt-get -y install gcc make autoconf libc-dev pkg-config plesk-php73-dev
    2. sudo /opt/plesk/php/7.3/bin/pecl install redis ( Accept the two default prompts )
    3. sudo service plesk-php73-fpm restart
    4. Ensure the redis checkbox is checked in the Plesk server-wide PHP settings at https://__yoursite.com__:8443/admin/php-handler/modules/id/plesk-php73-fpm

    • This reply was modified 1 week, 5 days ago by  neilelver.
    • This reply was modified 1 week, 5 days ago by  neilelver.
    • This reply was modified 1 week, 5 days ago by  neilelver.

    @xberg it is based on the php version you want to update, as also the linux software and version.

    As an example for php 7.2 everything went fine, but on php 7.3 i had to update the autoconf too.

    And dont forget after the php update to run this command also
    plesk bin php_handler –reread

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.