Support » How-To and Troubleshooting » Cannot configure or Arrange widgets.

Cannot configure or Arrange widgets.

  • I am unable to move any widgets while in Presentation/Sidebar Widgets. Also, I cannot configure any of them. There is absolutely no response to clicking or dragging; only highlighting. Furthermore, if I access the page with Firefox, my widgets for Sidebar 1 appear behind the creme-colored “Default Sidebar” box rather than below it.

Viewing 15 replies - 1 through 15 (of 35 total)
  • Try turning off any admin-themes and check to see if the /scriptaculous directory is in /wp-includes/js/

    I’m not familiar with admin-themes. Also, that directory does not exist in my installation.

    Well then you need to put it there.

    When you installed the widgets plugin, one of the things in the instructions was to move the scriptaculous folder (the one that came with the widgets plugin) into the /wp-includes/js directory. If you don’t do that then it doesn’t work, as you have discovered.

    Alright, I fixed that, but it hasn’t resolved my issue, and now the Sidebar 1 column appears above the Available Widgets Column.

    I just changed some security settings in my Internet Options, and that only changed one thing; namely, I can now drag the widgets. Clicking on the Configure box still does nothing, and the page display is still out of wack.

    Try deactivating any other plugins and test again?

    EDIT: And make sure you clear the cache.

    Alright, deactivating Now Reading 4.2 fixes the issue of not being able to configure any widgets, but the display is still messed up. The “Sidebar 1” column is completely left, while the “Available Widgets” column is below it and is nearly the full width of the screen with the widgets inside being mis-shapen as well

    I’ve even updated to the newest trunk of the widgets plugin now, and still nothing.

    Sorry, think I ran outta steam.

    It appears there have been multiple releases of “Version 1.0” of widgets.php. One I tried (from svn) has all the ‘unused’ widgets sitting in a box at bottom of screen. That one won’t work for me.

    Another one that I originally downloaded from Automattic (not the same one there now), has the ‘unused’ widgets sitting in a ‘sidebar’ arrangement on the left side of the screen, stacked vertically. That one does work for me.

    The included scriptaculous files changed as well. I see no difference in behavior regardless of those (either ‘version’ seems to work fine).

    Sorry about the lack of version numbers, folks. We’ll shore that up for you.

    The latest change (90 minutes ago) fixed a behavior like the one you describe, which only happens with certain themes. You can get the latest plugin file here:


    Just tried it, looks good so far (as in public page shows widgets). Very cool.

    Thanks! (Andy?)

    I’ve updated everything, and my problems persist. I don’t understand what I could have wrong.

    Nothing changes if Widgets is the only enabled plugin; except that deactivated widgets disappear, of course.

    Sure your cache is clear (browser/server/wp-cache)?

    In the latest version of Widgets plugin, I was able to make it work by just uploading the whole folder in the plugins dir. Didn’t moved the js to the wp-include/js folder.

Viewing 15 replies - 1 through 15 (of 35 total)
  • The topic ‘Cannot configure or Arrange widgets.’ is closed to new replies.