Support » Plugin: WP eCommerce » Cannot checkout!

  • I have a site at that sometimes works, sometimes does not.I cannot understand what the issue is. If you add a product to the cart and try to checkout, it will not let you elect any shipping options. If I go in and save my settings for the shipping options, it appears to work, but this keeps happening and I cannot figure out what is causing it to keep resetting like this. Anyone else experienced this? How can I fix it? Problem persists on different themes as well. We also are using a couple add-on plugins for this commerce solution: Gold Cart, WPSC variation images; could it be coming from one of those?

Viewing 10 replies - 1 through 10 (of 10 total)
  • I’m having the same issues, but haven’t received a response at all. It has been going on since the update on 01/17/2014. It’s quite frustrating. I’m about to scrap it and go to a different plugin.

    I have tried disabling every plugin except the Gold Cart and WP eCommerce, but still no change. I have also tried changing the current theme, and that didn’t work either. I have money invested in this, so either I want it fixed or expect a refund. This issue has happened before in the past and may or may not be related to updates, but the client did start complaining about it again when the update was released.

    Also a problem with the cart is happening; the cart only shows its contents right when you add it. If you come back later to the site, or you navigate away from the page and come back, it just says loading and doesn’t show anything – so then if they add that same product into their cart again, then there’s two of the product. It keeps the contents but doesn’t show anything in the cart.

    To debug this you probably want to start be disabling wp-super-cache and deleting the wp-content\cache directories.

    It could very well be that the theme you are using for WPEC is not created to be cache friendly when used with WPEC.


    I have had WP Super Cache installed before but it didn’t seem to make a difference 🙁

    I set it up according to basic guidelines HostGator has set (which are probably the same as anyone else would suggest), but maybe I’m not doing something right. How do you delete the wp-content/cache directories? Maybe I can try that.

    And the theme we used was purchased, so it might not be, you might be right. Not all of them are that great, I have noticed. It’s built on the Cherry framework. I can’t figure out why it seems to work sometimes and not others.

    I’ve just temporarily disabled all plugins but the Gold Cart one and WP eCommerce itself.

    Your site is still serving pre-generated (cached) files rather than freshly generated content. This means that the files being viewed by end users have the cart widget as it existed for the person that first viewed the page. when the person viewed the page. In the case of the store page I am looking at the page was created on Jan 30.

    You need to make sure that if disable wp-super-cache you delete the cache directories. You might also need to turn off wordpress caching to get the site into a working state.

    Once you have everything working add the caching back one step at a time to confirm that it isn’t contributing to the problem.

    This might not help but I had a similar issue that was a result of the product not having a valid weight assigned so the USPS API failed to return shipping prices and customers couldn’t proceed to checking out.

    might check the weights and maybe test with different products too.

    I’m having a similar problem.

    Any item that requires shipping does not proceed to gateway after clicking ‘purchase’. It just reloads the checkout page.

    Digital downloads and non-shipping items are working fine.

    I’m using a flat-rate shipping method.

    EDIT: I’ve tried deleting w3 cache directories as suggested above. Still no dice.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Cannot checkout!’ is closed to new replies.