WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] cannot change to code editor

[Resolved] cannot change to code editor

  • I have a visual bar for editing posts and it is impossible to change to code edittor.
    While I am copying my text from Word document extra line appears between paragraphs and it is impossible to get rid of it. I was able to do it a month ago but not now.
    How can I add code button in my editor?

Viewing 15 replies - 1 through 15 (of 21 total)
  • One suggestion – are you using the “Word” button to paste your Word text into the editor? If so, make your original Word document single-spaced and don’t add in an extra line yourself between the paragraphs. It should post it in correctly. At least it does for me.

    Not sure if this is your situation or not, but I thought I’d throw it out there.

    Also, about the not being able to go to the code editor, sometimes that’s a browser issue. You might try closing it out and opening it up again. Or you might try a different browser. I think it has something to do with scripting in the browswer (not sure though – others will know better).

    Thank you, I just tried it and it does not work.
    Yes, I use word button for pasting but after I press button below “Save and edit more” the extra line appears ans it show3es in preview.

    Before I had a code button, so I could erase extra lines myslef using code.
    Once when my blog was infected the owner of my server installed new editing bar, and now it is impossible to switch to code editor in my profile page.

    Someone installed new editing bar with code option but now there is not text in window. And no cursor appears there so I cannot post neither correct anything. What should I do?

    Please do not copy and paste from MSWord even if there is a button there for that. It’s not hard to save MSWord as plain text file and copy from plain text 🙂 Less headaches.

    Did you recently upgrade or was the HTML tab (located beside Visual tab posting area) missing since your first blogged?

    Quick fix – go to your User Profile and uncheck the “use the Visual Editor” near top of page.
    Good luck.

    Yes, in old editing bar there was HTML tab.

    I did checked and unchecked editors in my Profile but the window is empty and it is impossible to write anything there. What should I do?

    What do you mean by “the window is empty”? You mean you cannot write anymore in Post/Page?

    The post content window was not active and there was no way to put cursor there and write anything.
    Anyway my old editing bar was reinstated so it works now. I like this
    so called “turbo bar”, installed by my website server provider. It has more option for editing but the option of switching to code was turned off in MY Profile and it is not possible to switch to code anymore. I wonder if there is any chance to modify my editing bar and add code button to it.
    I imagine that switching to code I can erase empty line which is inserted to my text after I hit the SAVE and MORE EDITING button below text window. This empty line appears creating paragraphs when I do not want them to be.
    Thank you, Ekyo

    We cannot help you with custom modifications made to your system by third parties. We only know the default WordPress. Remove any plugins or modification that screw around with the editor if you want to make it work properly.

    I do not know how to do it myself. I can call and ask the owner of the server to do it for me. The bar was installed when my blog was infected and there were changes in all posts written before.
    If you can give some instructions how to do it I will try myself. Thanks

    Again, we cannot support custom modifications. This also means that we cannot tell you how to remove them. We don’t know anything about what this thing may have changed, so there’s no way for us to tell you what to do.

    If you’re going to run WordPress, try to run an unmodified one.

    So how do I switch to unmodified version?

    [Bold (Ctrl+B)] [Italic (Ctrl+I)] [Underline (Ctrl+U)] [Strikethrough (Alt+k)] [Select text color] [Select background color] [Remove formatting] [Ordered list (Alt+o)] [Unordered list (Alt+l)] [Outdent (Alt+w)] [Indent list/blockquote (Alt+q)] [Align left (Alt+f)] [Align right (Alt+r)] [Align center (Alt+c)] [Align full (Alt+j)]
    [Insert/edit link (Alt+a)] [Unlink (Alt+s)] [Insert an Image] [Insert/edit image (Alt+m)] [Emotions] [Dictionary] [Cut] [Copy] [Paste] [Undo (Ctrl+Z)] [Redo (Ctrl+Y)] [Split post with More tag (Alt+t)] [Split post with Page tag] [Edit HTML Source]

    For your info this bar was installed, and I imagine it is possible to get rid of it and add the original one, which someone did yeaterday dor me but after this adjustment the post window was not active and I could not write in it.

    Ekyo

    So how do I switch to unmodified version?

    You’re not hearing me. We have no idea. We cannot tell you that. We do not know anything about your “custom bar”, and so we can’t tell you how to undo it and go back to the normal system.

    Tell whoever installed it for you to remove their customizations and use the default editor. Or something like that. Only they know what custom stuff they did.

    If you have somebody else changing stuff for you, then you must work through them. We can’t fix things we don’t know anything about. We are not magicians.

    I will contact the man and ask him to undo whatever he has done…

    But I have another question. Is it possible to download the newer version of WordPress blog software to my computer and prepare and edit page or post while being off-line? And when ready than post it on line?
    My internet is hooked to phone and I am spending a lot of time editing my posts and blocking my phone line…

    If you need an offline editor, use something like Live Writer or any other offline blogging tool.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘[Resolved] cannot change to code editor’ is closed to new replies.
Skip to toolbar