Support » Fixing WordPress » cannot change status from draft to published on edit post

  • Resolved lake15


    I can add a new Post.

    Then, I view All Posts to see me table of all posts.

    From there, I can either choose Edit or Quick Edit under the title of each post.

    When I select Edit, I am UNABLE to change the Post Status from Draft to Published. My only options on the dropdown are Draft and Pending Review.

    HOWEVER, if I select Quick Edit, I AM able to change the post status to Published.

    I’ve tried other browsers, I’ve switched Themes, and I’ve deactivated all Plugins with no luck.

    Perhaps I should just use the Quick Edit page, but it still bugs me.

    Thanks in advance for getting this fixed.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Have you tried:

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress.

    Thank you.

    I just tried all of the items above and they did not solve the problem.

    I was able to determine that the Edit Page screen will not allow me to switch the Page from Draft status to Published either. The drop down only shows Draft and Pending Review.

    Hmmm. It seems that this ‘publish’ module is the problem for both posts and pages.

    <div id="post-status-select" class="hide-if-js">
    <input type="hidden" name="hidden_post_status" id="hidden_post_status" value="draft" />
    <select name='post_status' id='post_status' tabindex='4'>
    <option value='pending'>Pending Review</option>
    <option selected='selected' value='draft'>Draft</option>
     <a href="#post_status">OK</a>
     <a href="#post_status">Cancel</a>

    Any additional suggestions are appreciated.


    So, with the Quick Edit option, I see this code which IS PROVIDING the opportunity to change to status to Published.

    FWIW and for your help in troubleshooting.

    <div class="inline-edit-group">
    	<label class="inline-edit-status alignleft">
    	<span class="title">Status</span>
    		<select name="_status">
    			<option value="publish">Published</option>
    			<option value="future">Scheduled</option>
    			<option value="pending">Pending Review</option>
    			<option value="draft">Draft</option>

    [Moderator Note: Please post code or markup snippets between backticks or use the code button.]

    Using Phpmyadmin (or another MySQL management tool), first backup your database. Then navigate to your wp_usermeta table and locate the meta_key called “wp_capabilities” for your user_id. Change the meta-value for this record to:



    Thank you for your help. I did what you suggested above and was able to change it. No luck.

    FWIW – The previous value was



    It does sounds as if you’ve lost your Admin privileges – which is I was hoping that change would work. Did this happen after upgrading? Had anything else changed recently on the site?

    Try re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress.

    I did that. Still having the same problem.

    Looked at another blog I built on Same issue.

    Tried yet another browser and replicated the same issue.

    Just to be perfectly clear, this is what I’m seeing…


    Thanks again for your persistence.


    Something has definitely knocked you down to Contributor status. Did you try resetting the plugins folder using Phpmyadmin?

    I did the FTP version of resetting my plugins. Currently, the plugin page says “You do not appear to have any plugins available at this time.”

    The Contributor explanation does not explain why I can make all Post and Page status changes from the Quick Edit screen, but not the Edit screen.

    I just verified that option_value field is set to: a:0:{}

    Again, thanks – still curious of options.


    When did this problem start?

    This is a 10 day old WordPress site. It was discovered during testing.

    If you were to ask me, I could do a clean install via Bluehost or manually and I bet I would have the same problem.

    Are you a betting person? 🙂


    Yeh – go on. Try a fresh install and use a freshly downloaded copy of WordPress. Let’s see if this is server-related…

    I’m happy to say this is resolved, but I’m a bit embarrassed. This was an interface/user error, not a WordPress issue.

    I was looking for the word Publish under the pull down. Ugh.‹-Hawley-Page-—-WordPress.png



    Hi everyone,
    I was so excited about this post, coz I expected solution at the end 🙂 …I have exact same problem at exact same host.
    I’m admin, and cannot publish directly from post editor, only can save as draft, but I’m able to publish from posts list using Quick Edit.
    This happend to me after WP update to new version, but I did few things with that update too…for example I upgraded PHP version on the server. So, not sure witch one is responsible for the issue…
    Now, for testing purpose, I installed a fresh WP, from BlueHost’s Simple Script, and got same issue!
    Now, I’m sure it’s not WP related…its something on my server, but not sure what.

    Can anyone help?

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘cannot change status from draft to published on edit post’ is closed to new replies.