Support » Fixing WordPress » Cannot Change Permalinks on Images

  • Trible

    (@trible)


    In using one particular SSL plugin, a site I tend shows the logo as NOT having the necessary HTTPS in the URL.

    Tried the following:
    1.) Go to your Media Library
    2.) Find the Image
    3.) Click Edit
    4.) Locate the Permalink under the Title (BUT this option is no longer available)
    5.) Click Edit
    6.) Change the Permalink
    7.) Click Update

    So… deleting and re-uploading did not work to resolve this issue either.

    Please advise?

    Thank you in advance,
    Trish

Viewing 12 replies - 1 through 12 (of 12 total)
  • lisa

    (@contentiskey)

    can you share the link to your website so we can see the error

    Trible

    (@trible)

    @contentiskey
    Hi Lisa,

    There is no error to show… just no means of fixing the permalink.

    Here is a screen print of what I see once I get to steps 3 and 4
    https://www.eparrs.com/help/

    lisa

    (@contentiskey)

    i was hoping to see actual site link so I can inspect the logo.

    Trible

    (@trible)

    Sorry Lisa, but I’m sure you can understand that I cannot provide my customer’s site live. Offering the PDF like this I can simply delete it once you’ve seen what I see.

    lisa

    (@contentiskey)

    I understand. However, without the link, I am unable to provide feedback. I thought I could find the issue in source code or by inspection of css.

    Trible

    (@trible)

    If you can provide me with a private email address, I will GLADLY send you the link. If WordPress allowed us to edit out old tickets with URLs we no longer wanted displayed, I could offer you the URL… but presently that is NOT an option.

    Trible

    (@trible)

    This issue is still unsolved.

    sloanish

    (@sloanish)

    I have the same problem.
    The permalink assignment seems quite random.
    I uploaded a new picture and it gave it a post permalink from 4 years ago.
    I cannot see where to edit it.
    Permalink: https://captainmorsehouse.com/improvements-done-in-2016-spring-headline/

    Image
    https://captainmorsehouse.com/wp-content/uploads/0.0-Captain-Morse-House-Exteriors-View-From-North-Water-Street-157_Lg.jpg

    I am using real media library
    Hopefully that is not causing this

    Hi,

    1.Go to media library
    2.Pick the image you want to edit
    3.Click in “edit more details” which should be to the right of the screen under “copy url”
    4.This should take you to “edit media” page; look at the top right of the screen next to help and you will see SCREEN OPTIONS. Click on that.
    5.You will see a list of options. Under “boxes” select “SLUGS”; you should see a tick in the box.
    6. Scroll back down to the bottom of the page under the image. Right at the bottom you will see a new field “slug”. The current name of your image will be written in that box. You can then change the name to whatever you want.
    7. Under “save” click “update”.
    8. You now have a new permalink with the name you have just picked. Ie https://mywebsite/name-of-image-i-have-just-changed
    (Please note that as far as I know this only works if your permalinks are set to “post name”. To change to this go to Dashboard/Settings/Permalinks. Once on that page select “post name” under common settings.
    This is a serious change as it affects all your permalinks on your website do it with some thought)

    Hello, after I look for changing the image’s permalimk for hours I finally found the solution who is really hided !! No need of plugin or anything :

    In the media gallery go to the top right and click on the button Screen Options then select “slug”.

    After this you will find at the bottom of the page one field to complete and it will change your permalink address.

    kvandenbrule

    (@kvandenbrule)

    I was about to loose my mind with this. Thank you @wkinthia
    That works very fine.

    Jeeze! Thanks so much @wkinthia

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.