Support » How-To and Troubleshooting » Cannot change permalink to original post?!

Cannot change permalink to original post?!

  • I have been trying to create a page at http://www.Hoddick.com/2013 however every time I enter that permalink and press update it makes the page “www.Hoddick.com/2013-2”. I have tried everything I read on here such as deleting the “www.hoddick.com/2013” original post, but it isn’t in the trash or anywhere to be seen. Why can’t I name this page?!! When I go to “www.hoddick.com/2013” it says “page not found” so why can’t I create a new page here?!!! any help would be greatly appreciated as I am very frustrated currently. thanks!!!

    I am using photocrati theme if that helps!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The first thing to do is check the trash in pages, posts, categories and any other custom post types or set up that you have because there’s something that’s already using that URL. 99% of times it’s a post/page in the trash.

    This might not work but try to go into Settings -> Permalinks and click save without changing your permalink settings then go back and try to create the post.

    What this will do is force WordPress to flush the permalink rules and it might be able to do the trick.

    However I’ve not tried it’s most likely because a previous permalink with that structure was created and trashed, an entry still might exist in the database and flushing the rewrite rules might fix it.

    But yeah just a suggestion, it might not work but it’s worth a try. I’ll try to do a quick test on my development platform and see if I can re-create it and find a fix.

    Just tried out what I mentioned about going into Settings -> Permalinks and saving again without changing the rules and it seemed to do the trick on my development platform.

    Let me know if it works for you.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Cannot change permalink to original post?!’ is closed to new replies.
Skip to toolbar