Support » Fixing WordPress » Cannot change permalink

  • Hello everybody,

    I am not able to change the permalink of my one page website, it does not mention a EDIT button near the permalink

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Hi @trappeniersmichiel

    How is your permalinks setup in Settings -> Permalinks?
    Is it set to plain? If so, try changing it to “Post name” – that should do the trick.

    Best regards
    Aris Kuckovic

    Thread Starter trappeniersmichiel

    (@trappeniersmichiel)

    Dear Aris,

    Thanks for your reply, the setting was already at Post name, but that didn’t let the EDIT button appear šŸ™

    Hi @trappeniersmichiel

    Okay, that was worth a try.
    Now – are you using Gutenberg or the classic editor?
    Also, can you send a printscreen – just so I can check.

    Best regards
    Aris

    Thread Starter trappeniersmichiel

    (@trappeniersmichiel)

    Dear Aris,

    Can I have your email so I can mail the printscreen to you? Apperently I cannot past photo’s in a comment.

    I use WPBakery Page Builder

    Best regards,
    Michiel

    Hi @trappeniersmichiel

    I would love to give your my email – but it’s in the interest of this forum to keep the dialogue in here, in order to help others having the same issue.

    If you could upload your printscreen to Imgur, then you can paste the link in here šŸ˜€

    I hope you understand.

    Best regards
    Aris

    Hi @trappeniersmichiel

    The page you linked to is your homepage, just to confirm was this the correct page to review?

    The page I need help with: http://www.smile-4-me.be

    You cannot change the permalink of this page in the page editing admin area, you can only update the slug of child pages. To edit the main url you need to do this in Setttings > General, or assign a different page to be the homepage and create/update the url of the page you have linked to.

    If you can confirm that the url you provided was the right one?

    Kind regards,
    Charlene

    Thread Starter trappeniersmichiel

    (@trappeniersmichiel)

    Dear Aris,

    My excuses for the delay, this is the link of the printscreen: https://imgur.com/f61COlU

    Thread Starter trappeniersmichiel

    (@trappeniersmichiel)

    Dear Charlene,

    That is indeed the correct page and that is my homepage.

    I am really not a pro in WordPress, I would love to add the keyword: Photobooth-huren to the URL to optimize my URL. My website is a one-page website. If I will update the URL of my homepage, under the General settings, do I need to update both the WordPress Address as the Site Address? Will it help for my SEO?

    Also what are child pages? Do I have them with a one-page? + Could I change them to improve my SEO?

    Appreciate your help,

    Michiel

    Thread Starter trappeniersmichiel

    (@trappeniersmichiel)

    Charlene,

    I edited the URL in the General tab, but now my site cannot be loaded and shows this error:

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator at webmaster@smile-4-me.be to inform them of the time this error occurred, and the actions you performed just before this error.

    More information about this error may be available in the server error log.

    PLEASE help

    Hi @trappeniersmichiel

    Apologies, I was not advising you change your site name without checking first only trying to confirm the page you needed to change. You will need to edit your wp-config.php file with the following to change it back:

    define( 'WP_HOME', 'http://example.com' );
    define( 'WP_SITEURL', 'http://example.com' );

    You can do this through an FTP setting, try changing it in the database – if you have no access to this contact your host.

    Changing The Site URL

    Since your site is a 1 page site, you cannot change your home url easily – if you want to add keywords to your site for optimization you will either need to have a different url (buy one) or use SEO settings to improve your site.

    Kind regards,
    Charlene

    Hi @trappeniersmichiel

    Can you send a screenshot of the edit-screen when you’re editing your post?
    It sounds silly that the change permalink button is not there.

    Thread Starter trappeniersmichiel

    (@trappeniersmichiel)

    Dear @cmspencer99,

    I was able to solve the problem :).

    Dear @kuckovic,

    This is the link to the printscreen: https://imgur.com/P2DfZ4I.

    Thanks a lot,

    best regards,

    Michiel Trappeniers

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Cannot change permalink’ is closed to new replies.