Support » Fixing WordPress » Cannot change my email address

  • Hi, I’ve been using wordpress for quite some time now and it’s great. However, I am unable to change my email address. It says that it has sent a confirmation email to my new address, but I am not getting any. I’ve tried changing the email address for the user in phpadmin but still no use. Any help will be greatly appreciated. Thanks a lot!

Viewing 11 replies - 1 through 11 (of 11 total)
  • Moderator t-p

    (@t-p)

    I’ve tried changing the email address for the user in phpadmin but still no use.

    What happens? The change or new email does not take effect? Or, it won’t let you enter new email?

    Hi, thanks a lot for replying. I was able to change the email address in phpadmin but when I try to change the email address in wordpress, nothing is happening. It just says that a verification email has been sent to the new email id but I am not getting any email on the new id. Hope it clears it.

    Really looking forward to your reply. Thanks!

    Moderator t-p

    (@t-p)

    I was able to change the email address in phpadmin

    Glad to know it 🙂

    but when I try to change the email address in wordpress, nothing is happening.

    Contact your hosting provider and ask them why? It has nothing to do with WP. Ask your host if you need to install SMTP. If you do, you can check out plugins .

    Hi, thanks for replying. I contacted Godaddy and they said that the email has been changed from their end. But I am still not able to change it from general settings, nor am I receiving any confirmation mail on my new address. Kinda stuck here.

    I also tried to change it from /wp-admin/options.php but when I click on save changes, it shows error with the page and doesn’t update it. Really have no clue what to do.

    Looking forward to your response. Thanks!

    kasidya, I am having the same issue. When changing the email address and updating, I get a message that says, “Your email address has not been updated yet. Please check your inbox at e**l@g****d.com for a confirmation email.”
    The confirmation email never comes.
    Did you ever get your issue resolved?
    Thanks, -gb.

    • This reply was modified 10 months, 2 weeks ago by  geneboyd.

    Hi, I wasn’t receiving confirmation emails for either 1) changing my user (admin) email address or 2) changing the main email field in General>Settings. Then, I disabled WP Forms and the WP SMTP Plugin and re-triggered both types of confirmation email change. The User email now works and is changed! The General>Settings one is still stuck. I suspect another plugin, but don’t have any obvious suspects at this point. I guess I’ll disable them all one by one and then test and add them back one by one.

    I just found a workaround. Go to this link: https://yourdomainname.com/wp-admin/options.php. (just copy and paste- apparently you can’t find this page any other way) Do a search for the old email (the one you are ditching) and replace with your new one. Save. Now you don’t need the email confirmation.

    @technicalcat I’ll give that a try and post my results. Thank you! Happy New Year!

    Hi. I too am waiting patiently for the contact email address to change to the new one I have. It has been pending for some several days and no one I assume has approved the change. Who is responsible for approving it. It says, “If you change this we will send you an email at your new address to confirm it. The new address will not become active until confirmed.”. I tried the link above but does not work. Any advice to fix this problem would be appreciated. Thanks

    I’m having the same issue (exactly). I’ve changed admin emails previously with no problem – about 2 years ago. Any help appreciated.

    jrbartlettjr

    (@jrbartlettjr)

    same problem here. when I go to /options.php as suggested above — it shows the new email address just fine BUT it does not change in the Main Settings Page. Please WordPress, figure this out.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Cannot change my email address’ is closed to new replies.