Support » Plugin: WooCommerce Cart Stock Reducer » Cannot change “ignore order status”

  • Lately I’ve had orders that are stuck in “pending payment” status for a very long time. My woocommerce “hold stock (minutes)” setting is 45 minutes, as is my “expire time” in cart stock reducer. But I’m getting orders “pending payment” for hours. The orders aren’t automatically canceling, and the items are not expiring from the carts.

    Could there be a conflict with the latest version of the plugin that’s causing my orders to not expire? I either need the orders to expire or I need the plugin to not ignore the “pending payment” status.

    When editing the “ignore order status” field, I can select a status other than “pending payment”, but when I click the “save changes” button it reverts to “pending payment.”

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author James Golovich


    If you have “Pending Payment” selected for “Ignore Order Status” then it certainly won’t expire those items. With that type of field if you want to uncheck everything it seems you have to Ctrl + Left Click on the entry to unselect it, though selecting another status should also change that. I just tested removing a selected status and it appears to work fine on my test setup.

    What version of the plugin are you using and what version of WooCommerce?

    Thanks for the quick response. I’m using the latest versions of woocommerce and cart stock reducer.

    It seems the Ignore Order Status field issue is browser-related. I was using Safari when i had the problem. I was able to change the selection with Firefox.

    But I still don’t know why orders that aren’t completed within 45 minutes are not auto-cancelling. You’re not aware of a conflict that causes that issue?

    Plugin Author James Golovich


    I am not aware of any conflict but it is not a feature I use. When I have some free time later today or tomorrow I will see if I can duplicate the issue. Are you using any other WooCommerce related plugins?

    Yes, there are several other woocommerce extensions, but nothing that seems like it would relate to this issue. Let me test a couple things on my staging site before you spend time on this, and I’ll get back to you if I can’t resolve it. Thanks for the help.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Cannot change “ignore order status”’ is closed to new replies.