Support » Plugin: Master Accordion ( Former WP Awesome FAQ Plugin ) » Cannot be activated under TopClass 3.0.2

  • Resolved mumbomedia

    (@mumbomedia)


    Today I updated a customers website which use your theme TopClass https://themeforest.net/item/topclass-multipurpose-business-corporate-theme/9094711.

    I also update the theme from 3.0.0 to 3.0.2

    But when I try to activate the plugin it get this error message:

    Fatal error: Cannot redeclare add_js_plugin() (previously declared in /wp-content/themes/topclass/lib/shortcodes/tinymce.button.php:25) in /wp-content/plugins/wp-awesome-faq/lib/tinymce.button.php on line 25

    I compare the files and they are equal.
    Only the included file jwtheme.tinymce.js differs.

    I have the prefix jwtheme_ to topclass_ and also add this prefix to the add_js_plugin function in /wp-content/themes/topclass/lib/shortcodes/tinymce.button.php

    Now I was able to activate it.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Thread Starter mumbomedia

    (@mumbomedia)

    Also strange that when the plugin is active fontawesome isn’t enqueued.
    After deactivating it, the site looks as it should.

    Plugin Author Liton Arefin

    (@litonice13)

    Hello @mumbomedia,
    Great to know you’ve resolved it. Please contact on our Support forum.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Cannot be activated under TopClass 3.0.2’ is closed to new replies.